1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't set permissions for IUSR with Filemanager

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by GlennT, Aug 21, 2010.

  1. GlennT

    GlennT New Pleskian

    24
    57%
    Joined:
    Jun 18, 2009
    Messages:
    19
    Likes Received:
    0
    I'm using Plesk 9.5 and I cannot change IUSR permissions using Plesk's built in filemanager. I select IUSR_client and add write permissions to a folder or file and click OK. Plesk tells me permissions have been successfully changed but when I return to double check the changes aren't there or have been applied.

    I've been doing it manually for clients but this is a real problem and I'm hoping someone knows how to fix this.

    Thanks for your help.
    G.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Could you please provide more details how it can be reproduced? Where is this directory located?
     
  3. GlennT

    GlennT New Pleskian

    24
    57%
    Joined:
    Jun 18, 2009
    Messages:
    19
    Likes Received:
    0
    This problem happens if I try to change IUSR_xxxx permissions on any folder or file inside the httpdocs folder using the control panel file manager. It doesn't matter what domain I'm working in. I make the change but the change doesn't stick.

    Hope that info helps. There's not any more to it than that.
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Try to remove .Security file from domain's vhost root directory and reproduce this problem again. (File will be recreated automatically).
     
  5. GlennT

    GlennT New Pleskian

    24
    57%
    Joined:
    Jun 18, 2009
    Messages:
    19
    Likes Received:
    0
    I tried that and it didn't work and also reconfigured permissions.
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Ok. I have submitted request to developers and I will update thread with results of investigation as soon as I receive it.
     
  7. dimensions

    dimensions Basic Pleskian

    24
    57%
    Joined:
    Aug 28, 2002
    Messages:
    50
    Likes Received:
    0
    Facing the same problem after migrating data from 32BIT to 64Bit Plesk 9.5.2.

    The IIS is looking for some non existent web.config file which is not present in the /HTTPDOCS folder. I have tried removing the domain reconfiguring it but nothing works.

    Seems to be a bug in plesk control panel.
    Anybody has had any luck resolving this issue?
     
  8. Gaurav KumarS

    Gaurav KumarS Guest

    0
     
    Hello,

    You can change the permissions from web directories option.
     
Loading...