• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

can't start a cgi script.

H.W.B

Regular Pleskian
Hello,
I changed for a server with plesk 11.5 to plesk 12.5
Since then i can't start a cgi file.
I got an error 500.
In the error log of the domain i got the following error :
[cgid:error] [pid 26251:tid 140719033415424] [client 150.70.188.165:54854] End of script output before headers: backupsmanager.cgi
In the error log of httpd :
Can't locate CGI.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at backupsmanager.cgi line 946.
BEGIN failed--compilation aborted at backupsmanager.cgi line 946.
On the line 946 there is the following :
use CGI;

This script was working on the server with 11.5 but now i can't get it function.

Can anybody tell me how to get it working

Thank you

Henk
 
Make sure that you have installed perl-CGI package. For example, on my test Plesk 12.5 server I see:

[root@ppu12-5 ~]# rpm -ql perl-CGI | grep CGI.pm
/usr/share/perl5/CGI.pm

So, install it with

# yum install perl-CGI
 
Back
Top