• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Can't Start Reverse Proxy Server (nginx) - All websites down

SoleTrader

New Pleskian
Hi,

We're having a problem on one of our servers resulting in all websites down. Nginx won;t start and we get the following error:

Not starting nginx as it is disabled in config

The following article relates to this on Plesk troubleshooting, but none of the solutions are helping to resolve this.

http://kb.odin.com/en/126290

Can anybody help with possible further solutions?

Any help will be greatly appreciated!
 
Any errors in nginx log file after starting this service manually in CLI?
 
Have you tried

# plesk repair web

if you have 12.5 version?
 
We are indeed on 12.5.30

I have just run that command and unfortunately no luck. We have rebooted the server a few times and run the bootstrapper repair and also updated cent os packages also.
 
As a sort of fix, I have just uninstalled nginx completely via the components installer. Is there any problems with us doing this? Obviously it's not really a fix as such so any further suggestions would be greatly appreciated.
 
This has happened a couple of times to me. Try this command:

/usr/local/psa/admin/bin/nginxmng --enable
 
Back
Top