1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't turn spamassassin on

Discussion in 'Plesk for Linux - 8.x and Older' started by kerm1t, Dec 22, 2008.

  1. kerm1t

    kerm1t Guest

    0
     
    If I attempt to turn SA on for a mail account, it appears to work (I get the message '... has successfully been enabled for this account'), but when I go back to the list of mail accounts on that domain, it isn't showing as set.

    If I look at the user's .qmail file, it doesn't contain the call to spamc, and any mail coming in to the account doesn't have SA headers in it. So I'm pretty sure SA isn't being turned on for the account (as oppose to it being turned on, but Plesk not reporting it as enabled).

    I've tried using spamassassin.sh to manually enable it. Again, it claims sucess, but when I view the user's spam settings (with the -i switch), it still shows as disabled.

    I've checked the permissions on /var/qmail/mailnames and its subdirectories: all the files belong to the popuser user and group, and are rwx for this user.

    Any thoughts? It's a fresh Plesk installation (on CentOS if it matters)
     
  2. Satoriya

    Satoriya Guest

    0
     
    Please, run /usr/local/psa/admin/sbin/mchk utility to get mail settings configured through Plesk CP synchronized with SA and Qmail.

    After that try enabling spam filter for mail account one more time.
     
Loading...