1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

CDNS Debian allow-recursion

Discussion in 'Plesk Expand 2.3 Troubleshooting Issues' started by VIB-host, Oct 14, 2008.

  1. VIB-host

    VIB-host Guest

    0
     
    Hi

    I¨m trying to add recursion paramters to my dns server on debian. However if I place it in any of the named.conf named.conf.local or named.properties under /etc/bind/ the system don't care and do response to all

    If i put this in any of the above files under /var/named/run-root/etc/bind/ I can't start bind again.

    the following lines are those i try to add:

    options {
    allow-recursion {
    "none";
    recursion no;
    };
    allow-transfer {
    x.x.x.4;
    x.x.x.5;
    }
    allow-query {
    127.0.0.1;
    };
    };

    can anyone tell me how to do this on debian 4.0 R4a I386?
     
  2. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    You can look errors in /var/log/syslog file.
     
  3. VIB-host

    VIB-host Guest

    0
     
    well I get this error, but i don't know why

    Oct 18 17:00:06 localhost named[22772]: starting BIND 9.3.4-P1.1 -u bind -c /etc/bind/named.conf -t /var/named/run-root
    Oct 18 17:00:06 localhost named[22772]: found 1 CPU, using 1 worker thread
    Oct 18 17:00:06 localhost named[22772]: loading configuration from '/etc/bind/named.conf'
    Oct 18 17:00:06 localhost named[22772]: /etc/bind/named.conf.local:9: 'options' redefined near 'options'
    Oct 18 17:00:06 localhost named[22772]: loading configuration: already exists
    Oct 18 17:00:06 localhost named[22772]: exiting (due to fatal error)
     
  4. VIB-host

    VIB-host Guest

    0
     
    Found the solution....

    in /var/named/run-root/etc/bind/named.conf.options

    add the following line ad the end of the file, but before the last };

    allow-recursion { 127.0.0.1; };

    However, this will for some resone not refuse the request, but will point the client to the root servers
     
Loading...