1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

CentOS 3.6 Update Problem Fixed

Discussion in 'Plesk for Linux - 8.x and Older' started by Chris, Nov 19, 2005.

  1. Chris

    Chris Guest

    0
     
    I just want to post this in case anyone has a similar problem. I am running Plesk 7.5.4 with CentOS.

    I ran yum update and CentOS upgraded itself to 3.6. However, this broke cgi-bin scripts for all of the domains on the server (giving "Internal Server Error" with "Premature end of script headers" in the log files).

    It looks like the upgrade replaced Plesk's suexec with its own. I was able to fix this by:

    mv /usr/sbin/suexec /usr/sbin/suexec.old
    cp -p /usr/local/psa/suexec/psa-suexec /usr/sbin/suexec
    service httpd restart

    As always, use the above steps at your own risk (although this is not particularly dangerous). Other than the cgi-bin issue, no other problems with the update (so far!).
     
  2. musictus

    musictus Basic Pleskian

    24
    23%
    Joined:
    Jul 21, 2004
    Messages:
    58
    Likes Received:
    0
    Thanks for the tip!

    It solved also my problems!

    Is there a way to know when CENTOS automatically updates this suexec files?

    KR

    Walter
     
Loading...