1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

centos - plesk - apache file owner

Discussion in 'Plesk 11.x for Linux' started by Mike Mike, Nov 9, 2012.

  1. Mike Mike

    Mike Mike New Pleskian

    10
     
    Joined:
    Nov 9, 2012
    Messages:
    3
    Likes Received:
    0
    Hello, i have a question.

    Server:
    Centos 6 + Plesk 11
    save_mode = off;

    PHP support (run as Apache-module)

    Problem:
    I have a script that creates folders for users. mkdir('/var/www/vhosts/website.com/private/'.$user_id.', 0755, true);

    And true the Plesk API i create a ftp user for the new folder.
    The problem is that my php script create the new folder whit the following group and user: apache(502)/503

    The ftp users has no rights in this folder at all.

    If i create folders true ftp the group and user are: 505/10000

    How can ik fix this problem.
     
  2. DaveKay

    DaveKay Regular Pleskian

    17
    85%
    Joined:
    Jan 2, 2012
    Messages:
    226
    Likes Received:
    0
    Run PHP as FastCGI.

    Goto Subscription > Websites & Domains > Website scripting & security (under advanced) > PHP support. Select FastCGI application in drop down menu and save settings.
     
  3. Mike Mike

    Mike Mike New Pleskian

    10
     
    Joined:
    Nov 9, 2012
    Messages:
    3
    Likes Received:
    0
    I have tried that already, but then i have a other problem. fsockopen is not working in FastCGI modus.

    Warning: fsockopen(): unable to connect.
     
Loading...