1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Certificates between Plesk and IIS

Discussion in 'Plesk for Windows - 8.x and Older' started by MadPad, Jul 22, 2007.

  1. MadPad

    MadPad Guest

    0
     
    Hi there

    We have issued an SSL certificate hosting.ourdomain.com directly trough the IIS console, this was installed correctly and now our webmail (Smartermail) works with https://hosting.ourdomain.com without problems.

    So now we also want to fix this error message of Plesk when logging into https://hosting.ourdomain.com:8443 as this page is not running trough IIS (I think on appache) how can we insert the same certificate there, so it works also for Plesk?

    I tried exporting the private key, but IIS exports it encrypted so when I try to issue the certificate in Plesk I got the following to errors:

    "Unable to set the private key: Probably, the private key format is invalid." and "Some fields are empty or contain an improper value."

    So is there a way to get the certifcate from IIS also into plesk as both us the same IP and domain.

    Thanks for your help.

    Regards
    Patrick
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    You should
    1. Export certificate from IIS with option "Export private key".
    2. Convert it (http://kb.swsoft.com/en/750)
    3. Go to page Plesk > Server > Certificates and add it to repository
    4. Select it in Certificates list and click "Secure control panel".
     
  3. MadPad

    MadPad Guest

    0
     
    Hi Sergius

    Thank you a lot for the link. I did convert the certificate and were able to load it into plesk. (The optional CA Certificate was not accpted because of a wrong format (can it be converted aswell?) It's a .p7b file) But it did accept it without this certificate.

    I did select "Secure control panel" I rebooted, but it sill uses the default plesk certificate and brings the error. So I tried to delete the default certificate, but I could not be deleted because it is used somewhere (probably for the portal..).

    So how can I make it work, or delete the old one if I don't know where the cert is used.. and secondly is the CA Cert needed and if yes, can it be converted too.

    Thanks a lot.

    Kind regards
    Patrick
     
  4. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    You should
    1. Select in Certificates list other certificate and click Make default for Web sites
    2. Go to page Server > System > IP Addresses and change for each IP address property SSL Certificate from Default Certificate to other.
     
  5. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    CA cert is recommended. It can be converted too if certificate was exported with all chains.
     
  6. MadPad

    MadPad Guest

    0
     
    Great it worked like a charm, and no error anymore! Thank you very much sergius!

    One last question regarding IPs, we have our Plesk server in the DMZ behind our hardware firewall and mapped the public IP to the internal one in the DMZ. Now the "preview" of websites and some other features don't work anymore, as it uses this internal IP in the address bar of internet explorer. Is there a way to change this behavior so it uses always the external IP, without putting it directly onto the internet?

    Regards
    Patrick
     
  7. kpisman

    kpisman Guest

    0
     
    MadPad, unfortunately its not looks easy enough to implement.
    It is theoretically possible, but in my opinion will not work well.
    AFAIK guys from swsoft are working on this issue.
     
Loading...