1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

changing PHP settings does not work

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by YavannyY, Aug 13, 2010.

  1. YavannyY

    YavannyY Guest

    0
     
    Hello everybody,

    I have a problem to change the php settings for a subdomain. For example I tried to change the safe_mode setting. I created the file vhost.conf in the /conf folder under the subdomain path with the entry php_admin_flag safe_mode off. After that /usr/local/psa/admin/bin/websrvmng -a -v and apache restart. But the safe_mode is still on. It is not the first time I changed the php settings in this way but now I have the problem with every subdomain I create. The httpd.include of the domain seems to be ok: the path to the vhost.conf for the subdomain is correct.
    The Plesk Version is 9.3. and I did no upgrade before.
    PHP Version 5.2.4-2 and Ubuntu 5.10
    I use the setting php_apache module for the subdomain

    Does anybody have an idea to solve the problem?
     
  2. jas8522

    jas8522 Basic Pleskian

    24
    23%
    Joined:
    Feb 3, 2005
    Messages:
    80
    Likes Received:
    0
    Location:
    Halifax, Nova Scotia Canada
    Try disabling safe_mode for the parent domain - it should fix it. It's not really a solution per se, but rather a workaround.
     
Loading...