1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Compatibility to Plesk 8.2 ?

Discussion in 'Plesk Expand 2.1 General Discussion' started by CryoGenID, Jul 11, 2007.

  1. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Hey :)

    As Plesk 8.2 is just about to be released... Will it work with the current Plesk Expand?
    Or do we have to wait again for an update of Expand before we can use it?

    Thanks for your information!
     
  2. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Hmm, I do not remember a time when Plesk Expand was unable to work with any new Plesk released - Plesk always provide backward compatible API. The only problems with new Plesk were that older Plesk Expand were unable to be installed on the same host (due to they use shared component).

    So - yes, Plesk Expand 2.1 will work okay with Plesk 8.2.
     
  3. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Thanks a lot for your quick reply! :)

    We had a problem relating to an older Expand Version which didn't work with Plesk 8.0 if I remember right...

    But if it is working now, everything is fine :)

    Thanks again for your reply!
     
  4. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    Yes, I can confirm: Plesk 8.2 (Running on Debian 4.0) is working in combination with Expand 2.1.3
     
  5. webcie

    webcie Guest

    0
     
    But can I upgrade plesk on the expand-server to 8.2?

    When I try I get this:

    Unresolvable chain of dependencies:
    expand-2.1.3-4_psa8.1 requires psa-security = 8.1


    Jef
     
  6. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    When Plesk and Plesk Expand are installed on one host there are common modules which must be same version. It applies some restrictions on upgrade. In such case upgrading Plesk to 8.2 requires Plesk Expand 2.2 which is coming soon.
     
  7. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    No we have a dedicated expand server. So we need expand 2.2 to have plesk 8.2 managing the right way?
     
  8. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    No, you do not.
    Plesk Expand 2.2 is required for those ones who has Plesk and Plesk Expand installed on one host.
     
  9. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    Okay I understand. But is there an way to fix this problem? the strange thing is, expand gives an error, but the domain has been created. It appeared directly in plesk and after a while also in expand.
     
  10. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    What is a error you are talking about?
    Can I see error details?
     
  11. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    @jovana:
    We also had this error (Ticket #278033)

    Second-Line Engineers told us that this would be solved in Expand 2.2... :(
     
  12. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    This error message is not any dangeroous, though I am sure it annoys a lot.

    Let me explain some internals -
    Plesk Expand has two operation flows. One sends commands to Plesk server (so you can create domain from Plesk Expand) and another receives notifications from Plesk server (so you see in Expand domains created though Plesk). Sometimes when one of hosts is slow or loaded too much, Plesk Expand receives notifcation from Plesk that new domain is created (second flow) BEFORE it receives confirmation that domain creation complete (first flow).

    Though the domain is created actually without any problems, some code considers that to be an attempt to use one domain name two times.

    The problem was discovered quite late due to it does not appear in fast environment at all.
     
Loading...