1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

component version is wrong

Discussion in 'Plesk for Linux - 8.x and Older' started by w3it, May 6, 2005.

  1. w3it

    w3it Guest

    0
     
    Hi
    I just upgraded MySQL using yum. When I check in the Plesk components it states mysql as the old version still. What does this mean, do I need to update Plesk somehow or am I really running the old version still!?

    Thanks
     
  2. defencer

    defencer Guest

    0
     
    There is a table in mysql "psa" database named Components.

    mysql> select * from Components;
    +-------------------------+-------------------------------+
    | name | version |
    +-------------------------+-------------------------------+
    | apache | 1.3.31 |
    | php | 4.3.2-14.ent |
    | mod_python | 3.0.3-3.ent |
    | bind | 9.2.2-21 |
    | courier-imap | 3.0.8-rhel3.build75050130.17 |
    | frontpage | 5.0.2.2634 |
    | jdk | 1.4.2 |
    | tomcat | 4.1.30 |
    | logrotate | 3.7 |
    | mysql | 3.23.58-1 |
    | mailman | 2.1.1-5 |
    | postgresql | 7.4.1 |
    | phpmyadmin | 2.5.3 |
    | phppgadmin | 2.4.2 |
    | proftpd | 1.2.9 |
    | qmail | 1.03 |
    | webalizer | 2.01_10-15.ent |
    | rblsmtpd | 0.70 |
    | mod_perl | 1.99_09-10.ent |
    | perl-Apache-ASP | 2.57-rhel3.build75050130.17 |
    | spamassassin | 2.63-0.2 |
    | drweb | 4.32.2-rh7_psa |
    | drweb-qmail | 4.32-rhel3.build75050130.17 |
    | psa-migration-manager | 7.5.2-rhel3.build75050202.14 |
    | httpd | 2.0.46-38.ent |
    | coldfusion | not_installed |
    | psa-qmail | 1.03-rhel3.build75050130.17 |
    | psa-proftpd | 1.2.10-rhel3.build75050130.17 |
    | psa-logrotate | 3.7-rhel3.build75050130.17 |
    | psa-spamassassin | 7.5.2-rhel3.build75050130.17 |
    | tomcat4 | 4.1.24-full.2jpp |
    | apache2-mod_perl | not_installed |
    | psa-bu | 7.5.2-rhel3.build75050130.17 |
    | stunnel | 4.04-4 |
    | psa-qmail-rblsmtpd | 0.70-rhel3.build75050130.17 |
    | psa-tomcat-configurator | 7.5.2-rhel3.build75050130.17 |
    | postgresql-server | not_installed |
    | psa-api-rpc | 7.5.2-rhel3.build75050130.17 |
    | SSHTerm | 0.2.2-rhel3.build75050130.17 |
    | psa | 7.5.2-rhel3.build75050130.17 |
    | psa-agent | not_installed |
    +-------------------------+-------------------------------+
    41 rows in set (0.00 sec)

    mysql>

    So I think plesk just get an information about components version from this table. I am sure it is possible to force plesk to refresh this table, but I don't know how. You can just change the version value by hand in this table. I beleave it will be OK.
     
  3. w3it

    w3it Guest

    0
     
    excellent, thank you.
     
  4. mohammednv

    mohammednv Guest

    0
     
    Excellent :)

    I used this command to edit psa-component table. It worked fine.

    mysql>update Components set version="4.4.6" where name="php" limit 1;

    :p
     
Loading...