• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Connecting to IMAP / SMTP with valid SSL, still get error

Fabric Eleven

New Pleskian
Hi there, i just recently got on the Let's Encrypt SSL band wagon. I have successfully encrypted my plesk install and then copied my SSL to the appropriate mail folders. Following the steps here:
https://kb.plesk.com/en/1062

There is actually a great script that does the above steps for you here: https://github.com/Powie/plesk_mailcert
..and yes i checked that they matched and restarted the mail server services.

However i still get a "this root certificate is not trusted" error when i set up email clients and it's reffering to the OVH (my hosting) certificate.
I even added the root certificate from https://www.identrust.com/certificates/trustid/root-download-x3.html to the end of the CA chain thinking that it might be the cause.

So i am a little stumped here..it's almost like my copied ssl is not being applied
I use this tool here: http://www.checktls.com/perl/TestReceiver.pl to test email, you can see what it will say if you put "[email protected]" in the email box

Thank you guys for your help!
 
Hi Fabric Eleven,
You are using Postfix, so you need to change...


/etc/postfix/postfix_default.pem

And it should contain..

Private Key
Domain Cert
Intermediate/s

You don't need to add the Root CA.
Then just restart Postfix...

# service postfix restart
or
# /etc/init.d/postfix restart

That should sort it out.
Regards


Lloyd
 
Last edited:
Thanks Lloyd! That's the first thing i did, i verified that both of the SSLs are the same, and i still get that error. Is there maybe some other service that needs to be restarted? When i verify it here https://www.digicert.com/help/ (use hive.fabriceleven.com if you want to see for yourself.) it works fine. Maybe i need to restart something else?
 
Back
Top