1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Constant "Alarm level changed" messages

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Pauli Jokela, Mar 30, 2011.

  1. Pauli Jokela

    Pauli Jokela Guest

    0
     
    Hey,

    I've been getting constant emails from Plesk with the topic "alarm level changed.".

    This started when I upgraded to Plesk 10 and I've tried various hardware configurations (running inside a VPS) to see if increasing the RAM might fix it, but the problem still persists.

    The site and services don't seem slow, load's low and everything seems fine, it just seems like Plesk is reading apaches memory usage a bit too well.

    On a daily basis, I might get 4-5 emails where the alarm level has gone from green -> yellow -> red and then back to green.

    Here's an entire alarm email, just for reference (had to snip a bit to make it fit):

     
  2. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    I have been getting that too since upgrade to 10.1. Would love to get a tip for fixing this.
     
  3. Pauli Jokela

    Pauli Jokela Guest

    0
     
    I've got a solution for this.

    Go to "Health Monitoring" and click on "Download Configuration File", which will let you download an XML file.
    Open it up in an editor of your choice and scroll down to where it says:

    And modify accordingly. I set the thresholds like this:

    Then just save the file and back at "Health Monitoring" click "Upload Configuration File".

    So far the alarm-spam has stopped. :)
     
  4. KirkM

    KirkM Basic Pleskian

    25
    73%
    Joined:
    Mar 27, 2007
    Messages:
    94
    Likes Received:
    0
    Thanks for that. I tried it and it cut the warnings down to about 1 per day. So I went in and did 90/80 for the limits. I don't want to hear from the panel unless things are truly critical. :)

    I think this should work out fine.
     
  5. GFEMajor

    GFEMajor Guest

    0
     
    i hvae the same Problem. I changed my config to:

    and

    but i still got the emails with changed levels.

    i also tryed it with your suggestion:

    but with the same result.

    Do you have any hints for me? Do i have to restart the Plesk Services to make the changes take effect?

    Greets Major
     
  6. Pauli Jokela

    Pauli Jokela Guest

    0
     
    Well, just to clarify, if it's Apache memory notifications, make sure you're inside the MemoryUsage tag, not the CPU one, so:

    After that, you shouldn't need to restart anything (though you could restarts psa, psa-health-monitor-notificationd and sw-collected if you felt like it).
     
  7. GFEMajor

    GFEMajor Guest

    0
     
    The Problem is solved since i updated my plesk version. But Thank you for your help
     
  8. iainh

    iainh Basic Pleskian

    26
    23%
    Joined:
    Jul 23, 2008
    Messages:
    64
    Likes Received:
    5
    Thank you for a very nice solution. Down loading and examining my monitoring alert file I see the issue; alarms for Apache, Mail, MySQL and Plesk itself are all set to 20% but of course this doesn't reflect actual usage. So on my VPS (2Gb) for instance:

    Service Mb memory Percentage
    Apache 400.0 21.9%
    Mail 18.7 1.0%
    MySQL 50.6 2.8%
    Plesk 9.4 0.5%
    Total memory used 26.2%

    So you can see settings of 20% for each service simply doesn't reflect the usage of the differing services, meanwhile I keep getting usually green to yeellow and back to green warnings about Apache, yet everything is running in RAM with no usage of swap and so things are hardly memory constrained.

    The thing to do seems not just to increase the alarm level for Apache but reduce the levels for others as if Mail (Courier and Postfix) climbed from 1 to 20% something very odd would be going on! What's more with the levels redistributed the alarms will still kick-in before things go bad as otherwise your alarms could exceed 100% and so in theiry not go off even though the box was flat out. So my thinking is to try:

    Service Yellow Red
    Apache 35.0% 50.0%
    Mail 5.0% 10.0%
    MySQL 10.0% 15.0%
    Plesk 5.0% 10.0%
    Total 55.0% 85.0%
     
Loading...