1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Control Panel Gone!

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by jspe377523, Jan 31, 2009.

  1. jspe377523

    jspe377523 Guest

    0
     
    Hi There,

    I am fairly new to Plesk 9 but I changed the default skin to Plesk Reflections and since then the panel has gone! Except the header with the logo at the top.

    I have tried changing the skin in the command line and the header changes but the interface never appears :(

    Everything seems to be working but I cannot make any changes.

    I hope someone can help.
     
  2. GnArZ

    GnArZ Guest

    0
     
    1&1?
    External Firewall blocks Port 11444!
     
  3. jspe377523

    jspe377523 Guest

    0
     
    Interestingly no not with 1&1. I went through some basics and realised the control panel looks for the full hostname servername.domain.com I ran a ping and nslookup and they came back failed. Initially went in to command line in ssh and added a domain alias with the utility for the fqn I was surprised to find it let me!! Since then I altered the dns zone for the server domain to include the correct A entry.

    The previous version 8.6 worked fine so I can only imagine the upgrade screwed up the zone or the original setup didn't include that entry when the isp set it up thus causing the problem when 9 was installed.

    Cheers
    James
     
  4. DirtyMonkey

    DirtyMonkey Guest

    0
     
    Hi James, any chance of a step by step guide?

    Thanks in advance, DM.
     
  5. jspe377523

    jspe377523 Guest

    0
     
    I am sure I can do that for you no problem. Watch this space.
     
  6. ziba

    ziba Guest

    0
     
    Hi,

    This happens because in Plesk 9 SSO (single sign on) is installed and configured (unless you selected not to install it). SSO is mainly used in Plesk 9 to allow integration with Plesk Billing.

    Anyway after it installs and configures SSO all login requests to Plesk panel are redirected to SSO server which is by default configured to HOSTNAME_OF_MACHINE:11444

    So if hostname does not resolve it fails to redirect and you get this error.
    To check current SSO settings you can use the following command:
    /usr/loca/psa/bin/sso -g

    To fix this problem you can either disable SSO or change hostname of SSO server to the one that resolves to IP address of server. You can use
    /usr/loca/psa/bin/sso --help

    for more info on utility usage.
     
  7. Eyecu

    Eyecu Guest

    0
     
    Thank You ziba that was quite helpful. I've been banging my head against my desk for the past day trying to figure it out and couldn't. That is exactly the issue with plesk not loading for me I disabled sso and viola plesk loads fine again.

    Thank you so much appreciated.
     
Loading...