1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Conversion of Plesk 7 dump file fails on Plesk 9.3

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Frogger, Apr 5, 2010.

  1. Frogger

    Frogger Guest

    0
     
    Hi folks,

    I have a Plesk 7.5.4 system running in a Virtuozzo 3 VPS. I have a brand new Plesk 9.3 system running in a Virtuozzo 4 container. I'd like to move all clients & domains from the Plesk 7.5.4 setup to the Plesk 9.3 system. I have been unable to do so.

    Following the KB article http://kb.odin.com/en/5864 I made a dump of my Plesk 7.5.4 system, viz:

    /usr/local/psa/bin/psadump -f Plesk7.dump --nostop

    This worked and I had a 3.7 gig Plesk7.dump file which I copied over to the Plesk 9.3 system. Then I tried to convert the Plesk7 dump to a Plesk8 dump (prior to converting it to a Plesk 9 backup) as the KB article says to:

    /usr/local/psa/bin/backup-convert convert --output Plesk8.dump Plesk7.dump

    This step fails and I'm at a loss what to do next. Here's what I get from the above command:

    /usr/local/psa/admin/share/backup_convert/commands/convert.py:8: DeprecationWarning: the MimeWriter module is deprecated; use the email package instead
    import MimeWriter
    Runtime error: not a gzip file

    The "import MimeWriter" output and the "Runtime error: not a gzip file" are separated by about 30 minutes. The conversion aborts with the runtime error.

    Does anyone have an idea how I proceed from here?

    Oh yeah, the Plesk 7.5.4 VPS is running Fedora Core 4 on a Fedora Core 2 host and the Plesk 9.3 container is running Fedora 11 on a Fedora 8 host.

    --
    Cheers,
    Rob
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    It is difficult to say what is wrong with initial dump file without deep investigation directly on your server. It is not trivial problem and I can suggest you contact support team for fixing it. Try to find error and reason of error with something like

    # tail -30 Plesk8.dump

    Also you can try to use Migration manager for this migration.
     
  3. Frogger

    Frogger Guest

    0
     
    Migration Manager mostly failed, I only managed to transfer over 4 clients using it. Plus it is incredibly slow: the servers are on the same switch and it takes MM over 24 hours to transfer 1.5 GB! Yet the Virtuozzo host systems get around 11 mbs transfer speeds.

    MM fails in Plesk 9.3 with the issue discussed in http://kb.odin.com/en/7021 which is why I was trying to do it manually.
     
  4. Frogger

    Frogger Guest

    0
     
    Hmm, I see no indication of what the problem might be from the Plesk8.dump file.

    - Rob

    tail -30 Plesk8.dump
    -- Dumping data for table `phpbb_words`
    --



    --
    -- Table structure for table `phpbb_zebra`
    --

    CREATE TABLE `phpbb_zebra` (
    `user_id` mediumint(8) unsigned NOT NULL default '0',
    `zebra_id` mediumint(8) unsigned NOT NULL default '0',
    `friend` tinyint(1) unsigned NOT NULL default '0',
    `foe` tinyint(1) unsigned NOT NULL default '0',
    PRIMARY KEY (`user_id`,`zebra_id`)
    ) TYPE=MyISAM;

    --
    -- Dumping data for table `phpbb_zebra`
    --


    INSERT INTO `phpbb_zebra` VALUES (2,53,1,0);


    --127.0.0.1.0.20332.1270527172.085.1
    Content-Type: application/octet-stream
    Content-Disposition: inline; filename=1c8933a33e05d77c9011d7683d207b01
    Content-Id: 1c8933a33e05d77c9011d7683d207b01
     
Loading...