1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Database error after update from 9 to 10

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Nabilk, Dec 7, 2010.

  1. Nabilk

    Nabilk Guest

    0
     
    after updating plesk to 10, none of the site can connect to the MySQL database.
    when i login to webadmin this error shows
    "Your PHP MySQL library version 5.0.90 differs from your MySQL server version 5.1.49. This may cause unpredictable behavior"
    and
    "The additional features for working with linked tables have been deactivated. To find out why click here."
    when i click here it shows me

    $cfg['Servers'][$i]['pmadb'] ... OK
    $cfg['Servers'][$i]['relation'] ... OK
    General relation features: Enabled

    $cfg['Servers'][$i]['table_info'] ... OK
    Display Features: Enabled

    $cfg['Servers'][$i]['table_coords'] ... OK
    $cfg['Servers'][$i]['pdf_pages'] ... OK
    Creation of PDFs: Enabled

    $cfg['Servers'][$i]['column_info'] ... OK
    Displaying Column Comments: Enabled
    Browser transformation: Enabled

    $cfg['Servers'][$i]['bookmarktable'] ... OK
    Bookmarked SQL query: Enabled

    $cfg['Servers'][$i]['history'] ... OK
    SQL history: Enabled

    $cfg['Servers'][$i]['designer_coords'] ... not OK [ Documentation ]
    Designer: Disabled

    $cfg['Servers'][$i]['tracking'] ... OK
    Tracking: Enabled

    the $cfg['Servers'][$i]['designer_coords'] ... not OK

    how can i fix this?


    System info :
    General
    CPU AuthenticAMD, AMD Athlon(tm) 64 Processor 3800+
    Version Parallels Plesk Panel v10.0.1_build109101029.18 os_CentOS 5
    OS Linux 2.6.18-194.11.1.el5
    Memory 3.83 GB
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    This warning is caused by the fact that version of mysql and mysqlclient installed on the server does not match. You can check it with

    rpm -qa | grep mysql

    and compare versions of mysqlclient and mysql. It is recommended that you upgrade mysqlclient to version 5.1.49 or downgrade mysql to version 5.0.90.
     
  3. Nabilk

    Nabilk Guest

    0
     
    how can i do that?
    thanks
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Contact support team if you are not familiar with Linux rpm package system.
     
Loading...