• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Issue Dependencies problem

MatteoFormenti

New Pleskian
Hi everybody,
I'm configuring a VPS for a costumer, it came with Ubuntu 14.04 and i tried to update to 16.04.01.
While it was upgrading, I received some error messages from Plesk (unfortunately I can't remember what the message was), the installation proceeded and the server restarted.
When I tried to access via SSH, it displayed the 14.04 version of ubuntu, and now, whenever I try to install or purge any package, I receive this error

Code:
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 plesk-core : PreDepends: pp12.0.18-bootstrapper but it is not installable
              Depends: log4cpp-plesk but it is not installable
              Depends: plesk-base (>= 12.0.18) but it is not installable
              Depends: plesk-service-node-utilities (>= 12.0.18) but it is not installable
              Depends: libpam-plesk but it is not installable
              Depends: psa-zendframework (>= 1.11.15) but it is not installable
              Depends: psa-phpmyadmin (>= 3.5.2.2) but it is not installable
              Depends: psa-phppgadmin (>= 5.1) but it is not installable
              Depends: plesk-aps-php-runtime (>= 11.6.0) but it is not installable
              Depends: libmyodbc but it is not installable
              Depends: psa-libxml-proxy but it is not installable
              Depends: sw-doctrine but it is not installable
              Depends: psa-pylibplesk but it is not installable
              Depends: psa-locale-base-en-us (>= 12.0.0) but it is not installable or
                       psa-locale-base-12.0.18 but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Unfortunately, even if I force-ignore the dependencies, Ubuntu tries to install them and the error goes on.
I also tried both the plesk-installer and plesk-remove script, but they both fail dureing the connection to the mySQL db.
Code:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Since getting to the server to do a manual installation of a new operating system would cost a lot and I've never tried installing an os over SSH...
Thank you very much for the attention!
Matteo Formenti
 
Hi,

your pp12.0.18-bootstrapper and psa-locale-base-12.0.18 points at you using plesk 12.0 , not 12.5 .
Which according to the following two documents is not (officially) compatible with the new Ubuntu 16.04

http://download1.parallels.com/Ples...12.0-for-linux-installation-upgrade-info.html
https://talk.plesk.com/threads/ubuntu-16-04-official-final-release-date-april-21st-2016.337463/

And though Plesk 12.5 allows for certain dist upgrades, Plesk 12.0 never has.
Sorry for the potentially bad news
Tom
 
Last edited:
Back
Top