1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Disastrously bad plesk 7.5 autoinstall

Discussion in 'Plesk for Linux - 8.x and Older' started by erik0, Oct 27, 2005.

  1. erik0

    erik0 Guest

    0
     
    I installed plesk 7.5 reloaded on a test server several months ago for some clients, and it went very easily.

    Now that it's time to go into production, the prod server's offline, and I'm trying to install plesk on it... and it's not working at all.

    I'm running a clean RHEL 3.6, brand new install. Tried to autoinstall plesk, it failed. Tried it again, after fixing the password for mysql.. and it failed again, in different ways. Deleted the /usr/local/psa directory, as the script itself suggests... and I still couldn't get past the last couple of rpm's. (horde, and imp, if I recall correctly)

    So then, I got to the point where the autoinstaller would exit, claiming that I have all the components installed. Which might be true, in the sense that the rpm's are in the rpmdb, but I don't have the /usr/local/psa directory, or the .psa.shadow file in /etc/psa... or the psa database in mysql. The autoinstaller apparently doesn't realize any of this.

    Figured I might as well r'n'r the server. Reinstalled clean as a whistle. More autoinstall failure. Pretty much back to where I've started, except a day later.

    What I guess I want to know is- do I even have any options? Can I recover from this half-installed condition, or can I even clean the psa stuff back off the system to try again? Is there any way to do this install without the script?

    I'll be more than happy to provide more info if anyone can help me, I'll post install log files, anything.

    Thanks in advance.
     
  2. erik0

    erik0 Guest

    0
     
    woohoo!

    Well, alright.

    I guess all I *really* needed to do was... troubleshoot the db problem... and then go and force-remove almost all the psa rpm's.

    I'd figured that if I did a
    rpm -e --nodeps psa
    that would get me back to zero, but I actually had to do that to most of the psa rpms in order to get all the directories and the db recreated.

    I still wish there was a *lot* more help from the installer script- the error messages in there were cryptic to the point of total uselessness.
     
Loading...