• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Distupgrade Debian 7 to Debian 8 and php-fpm/non-plesk vhosts

UweP

Regular Pleskian
Hi. It seems like I can't run php on any of my /etc/apache2/sites-enabled/*. If I enable the apache2 module, it says:
root@baby /etc/apache2/mods-available # systemctl status apache2.service
● apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2)
Active: failed (Result: exit-code) since Mon 2015-10-19 21:39:37 CEST; 7min ago
Process: 30015 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
Process: 28287 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SUCCESS)
Process: 30043 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Oct 19 21:39:37 baby.unityhub.eu apache2[30043]: Starting web server: apache2 failed!
Oct 19 21:39:37 baby.unityhub.eu apache2[30043]: The apache2 configtest failed. ... (warning).
Oct 19 21:39:37 baby.unityhub.eu apache2[30043]: Output of config test was:
Oct 19 21:39:37 baby.unityhub.eu apache2[30043]: [Mon Oct 19 21:39:37.555179 2015] [:crit] [pid 30052:tid 139767021995904] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You ne...o recompile PHP.
Oct 19 21:39:37 baby.unityhub.eu apache2[30043]: AH00013: Pre-configuration failed
Oct 19 21:39:37 baby.unityhub.eu apache2[30043]: Action 'configtest' failed.
Oct 19 21:39:37 baby.unityhub.eu apache2[30043]: The Apache error log may have more information.
Oct 19 21:39:37 baby.unityhub.eu systemd[1]: apache2.service: control process exited, code=exited status=1
Oct 19 21:39:37 baby.unityhub.eu systemd[1]: Failed to start LSB: Apache2 web server.
Oct 19 21:39:37 baby.unityhub.eu systemd[1]: Unit apache2.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
root@baby /etc/apache2/mods-available # a2dismod php5
Module php5 disabled.
To activate the new configuration, you need to run:
service apache2 restart

then it works again, but i get download links when i try to go to vhosts i configured myself. is there a fix?
 
ok I did a2dismod mpm_event and a2enmod mpm_prefork - does that interfere in any way with my plesk installation like php-fpm? can my hosts still use php-fpm?
 
Hello,

Mpm_event is recommended to use with php-fpm but it conflicts with mod_php.
If you need mod_php or mod_perl or mod_python you should disable mpm_event and enable mpm_prefork
 
Back
Top