1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

DNS Template

Discussion in 'Plesk for Windows - 8.x and Older' started by manos2000, Oct 16, 2008.

  1. manos2000

    manos2000 Guest

    0
     
    DNS Template on plesk so far does not allow to put A record for www host (Always replaced by CNAME)

    I put at template :
    www.<domain>. A <ip> , if i wanted a CNAME I would put a www.<domain>. CNAME ip. but always new domains have CNAME for www host even if i put A record in template.


    When we press a url in a browser then our machine asks the root servers for the name servers of the domain we typed.
    If it is an A record the Name servers reply with one lookup the ip of the domain. If it is a CNAME need 4 lookups.
    Actually all dns reporting servers (eg dnsstuff) display a warning if CNAME is used.

    thanks,

    manos
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello manos,

    Thank you for the report. The request is queued for the future releases.
     
  3. Kaylior

    Kaylior Guest

    0
     
    Further on this, I don't think its just www. records but ANY changes to the DNS template since 8.6.0.1. For example, I have created a customer webmail.<domain> A record entry in my template to point to my central mail server, however this is not added whenever a new domain is created. I have checked the databases dns_recs_t table and the values are correct so am at a loss where it is getting its template information from. I have even tried changing values in the template (EG mail.<domain> to point elsewhere) which always use the old values. Any ideas on how to fix this would be appreciated.
     
  4. Abacus

    Abacus Guest

    0
     
    Right, same problem here. DNS Templates did work until I had to install the hotfix because statistics didnt work anymore. Now the DNS Template ist broken. But you can reset the DNS Zone to default in domain -> dns, then the custom records are added. Hope parallels will fix this soon, its quite annoying to have a fix installed to solve a problem and then have about 3 new ones... that are much more annoying that the one before.
     
Loading...