1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Durring psadump MySQL won't restart

Discussion in 'Plesk for Linux - 8.x and Older' started by ArizonaSky, Nov 9, 2005.

  1. ArizonaSky

    ArizonaSky Guest

    0
     
    When I run "/usr/local/psa/bin/psadump -F -f /backup/psa-dump.bkp --domains-names=/backup/domains-to-backup"
    about 4 out of 5 times I get the following MySQL unable to start error. This happens on a VPS Plesk 7.5.4 server (CentOS 3.3) and a dedicated Plesk 7.5.4. (RH9)

    I tried chaning the InnoDB value in the my.cnf file but it made no difference.

    Any ideas on why this keeps happening...? Thanks...


    # ./psa-dump.sh

    ================================
    Load list for dumping ... done
    ================================

    Attempt to connect to MySQL server ... done

    ================================
    Checking packages installation ... done
    Postgres is not configured (unable to define pg admin login and password).
    Now all the PSA services will be stopped:

    /usr/local/psa/admin/bin/httpsdctl stop: httpd stopped
    Stopping Plesk: [ OK ]
    Stopping named:
    Stopping MySQL: [ OK ]
    Stopping Courier-IMAP server: [ OK ]
    Stopping imap [ OK ]
    Stopping imap-ssl [ OK ]
    Stopping pop3 [ OK ]
    Stopping pop3-ssl [ OK ]

    Stopping httpd: [ OK ]

    ===============================

    Now the MySQL PSA service will be started:
    Timeout error occurred trying to start MySQL Daemon.
    Starting MySQL: [FAILED]

    ===============================

    Attempt to reconnect to MySQL server ... Unable to find file mysql.sock, possible reason: mysql service is not started.

    Unable to reconnect to PSA database.




    -------------------------------------------------------
    -------------------------------------------------------
    Contents of /var/log/mysqld.log:

    051109 01:40:40 mysqld started
    051109 1:40:40 InnoDB: Out of memory in additional memory pool.
    InnoDB: InnoDB will start allocating memory from the OS.
    InnoDB: You may get better performance if you configure a bigger
    InnoDB: value in the MySQL my.cnf file for
    InnoDB: innodb_additional_mem_pool_size.
    051109 1:40:41 InnoDB: Started
    /usr/libexec/mysqld: ready for connections
    051109 1:40:48 /usr/libexec/mysqld: Normal shutdown


    051109 1:40:49 InnoDB: Starting shutdown...
    A mysqld process already exists at Wed Nov 9 01:40:52 MST 2005
    051109 1:40:53 InnoDB: Shutdown completed
    051109 1:40:53 /usr/libexec/mysqld: Shutdown Complete

    051109 01:40:53 mysqld ended
     
  2. jcortina

    jcortina Guest

    0
     
    Similar problem here

    Hello,

    I am having a very similar problem... The server has a cronjob at 2 AM every day running a backup, and at this time MySQL stops working.

    Did you find a source for the problem?

    Thanks
     
  3. ArizonaSky

    ArizonaSky Guest

    0
     
Loading...