1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

DWmail on Plesk 7.5.4?

Discussion in 'Plesk for Linux - 8.x and Older' started by ArizonaSky, Nov 17, 2005.

  1. ArizonaSky

    ArizonaSky Guest

    0
     
    Has anyone installed DWmail on Plesk 7.5.4? http://www.dominion-web.com/products/dwmail/ I know it worked with 7.0 but haven't seen anything since then. I asked DWmail but they seemed to not have had any experience with anyone on 7.5.4 yet. It has a really nice GUI.

    If you have managed to get DWmail working on 7.5.4 can you tell us how it went and what was necessary to get it to run with Plesk?

    The install seemed to go ok but when I access webmail I get the following errors. I added a vhost.conf file for the domain it's installed under but no luck yet.

    "Warning: Unknown(): open_basedir restriction in effect. File(/var/www/vhosts/mydomain.com/httpdocs/dwmail/index.php) is not within the allowed path(s): (/usr/share/psa-horde:/etc/psa-horde:/etc/psa:/tmp:/var/log:/usr/share/doc) in Unknown on line 0

    Warning: Unknown(/var/www/vhosts/mydomain.comt/httpdocs/dwmail/index.php): failed to open stream: Operation not permitted in Unknown on line 0

    Warning: (null)(): Failed opening '/var/www/vhosts/mydomain.com/httpdocs/dwmail/index.php' for inclusion (include_path='/usr/share/psa-horde:/usr/share/psa-horde/pear:.') in Unknown on line 0"

    Thanks...
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    Modify the domain's PHP open_basedir to add the needed paths. Do this per domain in the domain's vhost.conf file.
     
  3. ArizonaSky

    ArizonaSky Guest

    0
     
    Did that but get exact same error above unless I have it wrong. Here is the vhost.conf file contents:

    "<Directory /var/www/vhosts/mydomain.com/httpdocs>
    php_admin_flag safe_mode 0
    php_admin_value open_basedir "/var/www/vhosts/mydomain.com/httpdocs:/tmp:/usr/share/pear:
    /var/www/vhosts/mydomain.com/httpdocs/dwmail:/usr/share/psa-horde/dwmail:/usr/share/psa-horde:/usr/share/psa-horde/pear"
    </Directory>"

    I then did websrvmng -a -v and restarted apache and see the http.include file timestamp updated but I don't see any of those paths added to that file...none go past the httpdocs directory.

    Only other thing I can mention is that "/usr/share/psa-horde/index.php" file was replaced with a symlink to the dwmail installation: /var/www/vhosts/mydomain.com/httpdocs/dwmail/index.php" if that helps any.

    So if my vhost.conf is ok then is there anything to do here with the "include_path" or an .htaccess file?
     
  4. ShadowMan@

    ShadowMan@ Guest

    0
     
    I just noticed that you have what looks like a typo in your earlier post about the error messages, notice the '.comt', do you maybe have a typo somewhere in DWmail conf file?
    Often the Plesk recommended parameters for websrvmng do not always work right, try

    /usr/local/psa/admin/bin/websrvmng -u --vhost-name=mydomain.com

    Not sure if the symlink would be a problem, never tried it on that file before.
     
  5. ArizonaSky

    ArizonaSky Guest

    0
     
    When editing the error text before posting I must have missed a "t" when replacing my own domain name with "mydomain.com"


    "/usr/local/psa/admin/bin/websrvmng -u --vhost-name=mydomain.com"

    Yes already tried that many times....same errors...the http.include file doesn't seem to be updating at all.

    I'll just have to try some different things and see if it will update as the same errors with the same paths keep appearing.
     
Loading...