1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

E-mail on remote site

Discussion in 'Plesk for Linux - 8.x and Older' started by pran, Mar 17, 2005.

  1. pran

    pran Guest

    0
     
    I have a client whose e-mail system resides on a different network. He has a PHP script that sends an e-mail to a mailbox on the remote system. However, the mails are routed to the local system and are not sent remotely. I have disabled the e-mail service for that domain but it appears that mails are not reaching the intended destination.
     
  2. bruce

    bruce Guest

    0
     
    There's a post around here somewhere dealing with this issue, but you can do the following:

    Delete the domain from rcpthosts and virtualdomains (both in /var/qmail/control)

    Once you've deleted them, make sure to restart qmail.

    Bruce
     
  3. pran

    pran Guest

    0
     
    Thanks for the tip bruce! I think the method of turning off e-mail support for the domain removes the entries from the files you mentioned.
     
  4. anandpatilg

    anandpatilg Guest

    0
     
    Can you tell me the error you are getting or are the E-Mails straight away lost?
     
  5. pran

    pran Guest

    0
     
    The e-mails are delivered to the local user instead of the remote system.
     
  6. anandpatilg

    anandpatilg Guest

    0
     
    Please check the destination of mail.domainname.com
     
  7. non-guru

    non-guru Guest

    0
     
    Deleting the domain the control files does NOT fix as it used to on older versions that had that same problem.. in fact, the domain is NOT listed in ANY files in control area.

    I get the following message in the maillog:
    qmail: 1119909211.425181 starting delivery 3359: msg 7012805 to remote cxxxxx@xxxxxxxxxxxxxxxxx.com

    but then....
    starting delivery 3059: msg 7013055 to local 531-postmaster@xxxxxxxxxxxxxxxxxx.com

    My version: 75050509.16

    DNS is properly mapped in our dns servers to send it remotely, but after it starts the process the server seems to be redirecting it to the postmaster box.

    ========= FIX FOUND
    Looks like DNS was enabled on domain and was causing this, once I disabled DNS on the domain itself, emails sent remotely fine.
     
Loading...