• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Easiest way to disable Plesk

matthewbaynham

New Pleskian
I have Plesk on my VPS and everything was going fantastic until I installed php5-mysqlnd and now everything has stopped working.

I need php5-mysqlnd but I don't need Plesk.

Now my apache server won't start because Plesk is doing a configtest before it'll start and so my website is down.

I don't want to go through any lengthy process to uninstall Plesk unless I have to, I just want the easiest way to stop the apache server from doing it's configtest for plesk? So that I can have apache working even if Plesk is not working.
 
Hi matthewbaynham,

the init - script from your apache is not shipped with Plesk, it's part of your apache - webserver - installation. Please have a look at your file "/etc/init.d/apache" ( or "/etc/init.d/httpd" ) and have a closer look to this init - script.
If you desire a startup - script for your apache - webserver without tests, please have look around with Google and replace the one on your server. Be aware that the tests are done to make sure that your apache - service is able to be started for example and if not, to report failures/issues/problems, which should direct you to the right direction to solve such issues. The tests itself will help you to investigate the issues/problems/failures and are not preventing to start the apache - service. A non-starting apache-service results of a incorrect configuration.
 
You can probably remove Plesk and remove configtest from Apache start script, but it will probably only result in a broken server. If configtest is failing, then Apache probably won't work anyway. I think you real problem is in php5-mysqlnd - either it was not installed correctly or it is not working and thus it breaks Apache starting. You probably need to focus on a root cause which is php5-mysqlnd.

If Plesk later conflicts with php5-mysqlnd, then you can remove Plesk later.
 
Back
Top