1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Editing the Metabase

Discussion in 'Plesk for Windows - 8.x and Older' started by Prefict, Nov 29, 2005.

  1. Prefict

    Prefict Guest

    0
     
    We are on a Windows 2003 server with Plesk 7.5

    Enable Direct Metabase Edit is checked in IIS

    The problem we are experiencing is two fold

    It begins from a problem in the Plesk control panel that we are not able to create a virtual directory outside of the current domains document root and more importatnly that we can not use the plesk API to create that virtual directory.

    ok here's the plan

    We are creating a new client and domain using the API: at this point all is well

    However we then have to create a virtual directory called /store/ that points to a folder that exists on another domain so that only one installation of the store script exists on the server but every domain on the server can access this script.

    Ok so Plesk can not do this for us. Fine so the next step is to write code that can modify the IIS metabase.

    so we set the Enable Direct Metabase Edit in IIS to true and write our code all seems to go ok and our virtual directory is added to the metabase. Great! but two seconds later it is ovewritten by plesk and we are back to square one.

    So the question is does anybody know how to modify the metabase.xml and metaschema.xml file on a windows machine with Plesk installed?

    Any help or suggestions would be greatly appreciated.
     
  2. lboss

    lboss Guest

    0
     
    We prohibited creating a virtual directory outside of the current domains document root by security reasons.

    Plesk don't remove any virtual directories without direct command to do this.

    I think you tried to edit matabase.xml directly and IIS threw out your changes. Plesk try to use Active Directory or WMI interface to create virtual directory.
     
  3. lboss

    lboss Guest

    0
     
    "Plesk" => "Please"

    Or use C:\WINDOWS\system32\iisvdir.vbs. It is util to manage IIS virtual directories.

    Also there are other utilities for managing IIS metabase objects.
     
  4. Prefict

    Prefict Guest

    0
     
    If only this were true.

    We have tried using metaedit the MS utility for editing the metabase as well as metaexplore the MS IIS snapin.

    We have stopped IIS and made the change and then restarted it.
    We have tried to do the edit while IIS was running.
    We have even had a plesk technical support person on the phone while trying to do this and still to no avial.

    Their must be a way but I have yet to get the answer.
     
Loading...