1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Email - Doesn't work......

Discussion in 'Plesk for Linux - 8.x and Older' started by JoeBoo, Dec 23, 2004.

  1. JoeBoo

    JoeBoo Guest

    0
     
    I have not at all been able to get email to work! I have tried everything i can think of....

    runnin Plesk7.5 on a 1and1 server.

    Can someone fill me in on the steps to set up the MX server so that all my domain can have functionin email?

    I even went so far as to try to set up my email with an external ip( 1&1's pop IP ) and couldnt get it to work.......

    here is how my current template is setup...

    <domain>. A <ip>
    <domain>. MX (10) mail.<domain>.
    <domain>. NS ns.<domain>.
    <domain>. NS ns1.mydomain.com
    <domain>. NS ns2.mydomain.com
    <ip> / 24 PTR <domain>.
    ftp.<domain>. CNAME <domain>.
    mail.<domain>. A <ip>
    ns.<domain>. A <ip>
    ns1.<domain>. A 255.255.255.254
    ns2.<domain>. A 255.255.255.255
    webmail.<domain>. A <ip>
     
  2. ferrisr

    ferrisr Guest

    0
     
    i have 1and1 and i just upgraded and had the same problem. Do youhave spamassassin and qmail-scanner installed?
     
  3. EnigmaX

    EnigmaX Guest

    0
     
    same here..

    I got the same issue as well.. 1and1, and I've got ART's qmail scanner, freshclam and I will see what I can come up with..
     
  4. ferrisr

    ferrisr Guest

    0
     
    I yum removed qmail-scanner and all its dependencies and restarted the pop3/smtp processes. All works now (took about 12 hours for all the email that got clogged and never came through to come in)
     
  5. EnigmaX

    EnigmaX Guest

    0
     
    worked...

    I removed the qmail-scanner and the spamassasin to have
    everything back to normal. I noticed psa-spamassin but I have
    to look for the fix of "blank emails" coming through.
     
  6. ferrisr

    ferrisr Guest

    0
     
    did you get a lot of errors about removing configuration? I think that was the problem. My mail logs showed errors about not being able to fin destinations and not being able to use tmp files (either permission denied, or when there were 777'd it said it was unreadable). Then spamassassin wouldn't start after i tried a total redo of pop, and pop failed to start spam.... so i removed it and it worked.... dunno if they upgraded something which borke something else, or what :/
     
  7. EnigmaX

    EnigmaX Guest

    0
     
    email, removing it..

    I ended up uninstalling the qmail-scanner via yum remove but couldn't do the yum
    remove spamassasin so I had to remove it / force remove and ignore all errors.
    There was still a psa-spamassasin which I would get a blank email here and there
    so I removed the psa-spamassasin.

    Later I went into Plesk and noticed when I logged in there were more updates
    available which I than installed the 7.5.1, some skins and also downloaded/updated
    or re-installed Spamassasin via the control panel. That worked fine and installed
    successful but wouldn't show as installed or active until I logged off and re-login.

    Everything works fine except my php, webmail and that's about it so far, I've got
    another issue now for allowing Plesk install/update my Kernel.

    Right now my dilemma is if I reboot server might not boot up properly because of
    1and1's odd layout...
     
  8. JoeBoo

    JoeBoo Guest

    0
     
    i'm a newbie to Plesk and here are the things i see that are mail related...which ones need to be removed?

    Thanks,

    spamassassin 2.63-0.2
    psa-qmail 1.03-rh9.build75041208.19
    psa-qmail-rblsmtpd 0.70-rh9.build75041208.19
    psa-spamassassin 7.5.0-rh9.build75041208.19
     
  9. ferrisr

    ferrisr Guest

    0
     
    jsut the spamassassin one. not the psa ones
     
  10. JoeBoo

    JoeBoo Guest

    0
     
    $ rpm -e spamassassin
    error: Failed dependencies:
    perl(Mail::SpamAssassin) is needed by (installed) psa-spamassassin-7.5.0-rh9.build75041208.19
    perl(Mail::SpamAssassin::ArchiveIterator) is needed by (installed) psa-spamassassin-7.5.0-rh9.build75041208.19
    perl(Mail::SpamAssassin::NoMailAudit) is needed by (installed) psa-spamassassin-7.5.0-rh9.build75041208.19
    perl(Mail::SpamAssassin::perMsgLearner) is needed by (installed) psa-spamassassin-7.5.0-rh9.build75041208.19
    spamassassin >= 2.60 is needed by (installed) psa-spamassassin-7.5.0-rh9.build75041208.19

    :confused:
     
  11. JoeBoo

    JoeBoo Guest

    0
     
    got spamassassin removed and i still cant get any mail :confused:
     
  12. Cranky

    Cranky Guest

    0
     
    Does your maillog look lively? i.e. is mail reaching your server? If so, are there any errors?
     
  13. EnigmaX

    EnigmaX Guest

    0
     
    what I did..

    I removed spamassasin --force and psa-spamassasin than things went back
    to normal. Then on, from the control panel went to update, selected
    the spamassasin package which was not installed and let Plesk install
    it for me and things are working just fine.
     
  14. JoeBoo

    JoeBoo Guest

    0
     
    mail appears to be reaching the server....after a 20 secon delay it gets headers and such.....but nothing gets delivered..

    SPAM blocker for QMail daemon Dec 16, 2004 Dec 16, 2004 You have an up to date version
    SpamAssassin support Dec 16, 2004 Not installed
     
  15. JoeBoo

    JoeBoo Guest

    0
     
    it looks like i have alot of mail queued to be delivered, but qmail isnt doin anythign with it.....
     
  16. EnigmaX

    EnigmaX Guest

    0
     
    clear queue

    You might need to use the ./qmHandle to clear out the queue...
    worth a try but might loose email..
     
  17. JoeBoo

    JoeBoo Guest

    0
     
    it had NOTHING to do with Plesk......

    1and1 has some quirks you gotta get thru....

    there is a place in teh 1and1 CP that had to be changed to use the default MX server instead of the 1and1 MX

    you would think since the server's MX record is "default" that it would use that to begin with.....:rolleyes:
     
Loading...