1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

email is forwarding non-existant addresses

Discussion in 'Plesk for Linux - 8.x and Older' started by michaellunsford, Aug 10, 2006.

  1. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    email is freaking out

    I killed an old domain and made it an alias of a new domain. The old domain was told to reject non-existant addresses, as is the new domain. Now all the email from the old domain is being forwarded to the "forward to" address of yet another domain. What to do?
     
  2. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    -- bump --

    better description:

    www.example.net -- old domain
    www.example.com -- new domain
    www.unrelated.com -- site hosted on same server, but otherwise unrelated to the other two.

    1. example.net was "deleted" in the domain control panel. Email was configured to reject nonexistent email addresses.

    2. example.com was added in the domain control panel with example.net as a domain alias. Email is configured to reject nonexistent email addresses.

    3. somebogusemailaddress@example.net is being redirected to catchall@unrelated.com

    I'm guessing that the email configuration files have somehow been confused or corrupted. Is there a way to have plesk rebuild all the email configuration files?
     
  3. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    bump

    ideas? anyone?
     
  4. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    new info:

    Although the dns reports that the MX record for mail.example.net is pointing to mail.example.com, it is apparently going to the default domain on the server (which is capturing all incoming email).
     
  5. BDMM

    BDMM Basic Pleskian

    24
    90%
    Joined:
    Apr 28, 2005
    Messages:
    31
    Likes Received:
    1
    I am having the same issues as it appears alias accept all email addresses

    Emails are default forwarded to the email address set up in the main domain email preferences. Put a new forwarding address in the forward all emails to non existing users field and switch on email forwarding then switch it off again to reject non existing. This will at least forward the non existing emails to the alias domain to where you want. I am looking at how to fix this. Previously I had an entry in the /var/qmail/control/rejectnonexist however this doesn't seem to work with the alias domains and causes qmail to freak.
     
  6. BDMM

    BDMM Basic Pleskian

    24
    90%
    Joined:
    Apr 28, 2005
    Messages:
    31
    Likes Received:
    1
    Ok I think I have it figured.

    Go into the mail preferences of the main domain and switch to bounce with message and then save. Then go back in and set it back to reject non existant and save again. This will update your .qmail-default file and add records to the psa database. Hopefully that will clear up the problem

    I had bounce with message option switched off in my main server settings so wasn't able to see the option in the site control panel.
     
  7. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    awesome.... that did it...

    hooray! no more spam (or a whole lot less of it).
     
  8. phreakstorm

    phreakstorm Guest

    0
     
    I'm having the same problem but this fix won't work for me. The problem is that I have a domain alias that has been around so long it gets over a 1000 spams a day and they are bouncing instead of rejecting. The problem is that my host has a 1000 smtp message per day limit so those bounces are shutting down my smtp server before I get out of bed in the morning. I found the same thing you did, editing the rejectnonexist file freaks qmail.

    Does anyone know a way to set domain aliases to REJECT unknown receptient mail instead of bouncing it?

     
  9. BDMM

    BDMM Basic Pleskian

    24
    90%
    Joined:
    Apr 28, 2005
    Messages:
    31
    Likes Received:
    1
    This is what I used to do before Plesk introduced aliasing in 8. I haven't tried it since but it should work the same.

    You will need to change your MX records for the alias to point to mail.domain.com.

    In this example domain.com is the alias and domain2 is the primary domain

    TO SEND EMAIL DOESNT EXIST FOR USER REJECTION INSTEAD OF BOUNCE
    cd /var/qmail/mailnames

    ## add domain.com folder
    mkdir domain.com
    chmod 700 domain.com

    ## add .qmail-default file
    cd domain.com
    pico .qmail-default

    ## add following line
    |forward ${DEFAULT}@domain2.com

    ## where domain2 is the primary domain where it is to go to.
    chmod 600 .qmail-default


    CHECK REJECTION LIST AND ADD IF NECESSARY

    pico -w /var/qmail/control/rejectnonexist
    ## add domain.com

    service qmail restart
     
Loading...