1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

email not working with external clients

Discussion in 'Plesk for Linux - 8.x and Older' started by jasonfbc, Dec 26, 2006.

  1. jasonfbc

    jasonfbc Guest

    0
     
    We are running Plesk 8.1 on suse 10.1 64bit.
    Everything works fine except the email when using a client like outlook or mozilla thunderbird, I can recieve email but cannot send them. Horde web mail works perfect. I have been reading the forums for the last week and so far have not had any luck.

    This is the error I get from the log files
    Dec 26 18:04:57 fbclxsrvr pop3d: IMAP connect from @ [68.209.195.84]checkmailpasswd: FAILED: test@psnnetwork.com - no such user from @ [68.209.195.84]ERR: LOGIN FAILED, ip=[68.209.195.84]

    Here are the dns records
    70.154.20.54 / 24 PTR mail.psnnetwork.org.
    70.154.20.54 / 24 PTR psnnetwork.org.
    mail.psnnetwork.org. A 70.154.20.54
    ns1.psnnetwork.org. A 70.154.20.59
    ns2.psnnetwork.org. A 70.154.20.60
    psnnetwork.org. NS ns1.psnnetwork.org.
    psnnetwork.org. NS ns2.psnnetwork.org.
    psnnetwork.org. A 70.154.20.54
    psnnetwork.org. MX (10) mail.psnnetwork.org.
    psnnetwork.org. TXT v=spf1 mx
    webmail.psnnetwork.org. A 70.154.20.54
    www.psnnetwork.org. CNAME psnnetwork.org.

    authorization is set to SMTP
    server host name fbclxsrvr.fbcwbhost.local

    when I telnet into the system locally, this is what I get

    Trying localhost
    Connected to localhost.
    Escape character is '^]'.
    220 fbclxsrvr.fbcwbhost.local ESMTP

    no matter what IP address I try I get the same results with the firewall enabled or disabled. I have checked the dns records at dnsstuff.com and everything seems fine.

    I have tried to run the mchk utility as root from the command line and all I get is "command not found" when I looked in the /usr/local/psa/admin/sbin/ and the mchk executable is there

    Does anyone have any ideas or solution that can help me get this thing working.
     
  2. jasonfbc

    jasonfbc Guest

    0
     
    Come on now, with all the expertise on here I can't believe no one has any ideas. Please, I'm begging.
     
  3. Who-m3

    Who-m3 Guest

    0
     
    First step would be to verify the login name is "test" instead of "Test" or "TEsT". The login is case-sensiTiVE. Please excuse my use of case, it's just as part of the example.

    Second step would be to verify that you're using the right password (it, too, is case sensitive, but you already knew that one).

    Third step, the smtp connection is there, it's trying to send, so it ISNT a problem with the server not getting the info. It's a problem with the authentication. It should be one of the two above issues. Also, verify under Server -> Mail that you're set to use full login names, not short login names. Full logins meaning with the @domain.com, while short logins only use the "test" portion.

    Hope this helps you,

    -John
     
  4. jasonfbc

    jasonfbc Guest

    0
     
    I have verified that the account name and password are correct. Also verified it is set to full login names.

    the log file entry is dirrfent now

    Dec 27 11:07:09 fbclxsrvr pop3d: IMAP connect from @ [68.209.195.84]INFO: LOGIN, user=test, ip=[68.209.195.84]

    but it still does not work

    Thank you for the help John

    AJ
     
  5. blank_page

    blank_page Regular Pleskian

    24
    53%
    Joined:
    Dec 17, 2006
    Messages:
    229
    Likes Received:
    0
    Hello,


    Try to google on the error number that the mail client throws.

    Also check the smtp settings on your mail client.
     
  6. Who-m3

    Who-m3 Guest

    0
     
    After finally updating my main production server to "live" 8.1 status, I've realized that this is a much larger issue than I originally believed. This is currently hurting my Horde configuration, as the issue is with the login AND domain name, both of which appear to be Case Sensitive. For those of us who have clients with CaSE.Different.Domains, this means they are unable to login to webmail through horde.

    As of this posting, I'm looking for a fix to make this work the way it used to, as 8.0 didn't have this problem. Not sure if Plesk/SW-Soft is just trying to play with us, or if they've "fixed" a "bug" from previous versions. But this just doesn't make sense to me. I'll update you when I know more.
     
  7. Who-m3

    Who-m3 Guest

    0
     
    Ok, I found a temporary fix, until I can find exactly what settings is messing with "checkmailpasswd" and it not accepting different case in the @DomAIn. I've modified the /var/qmail/users/poppasswd file (format login@domain:password:maildir, or something along those lines). I've dropped the case on the @domain portion, tested, and this did re-enable my webmail on the "test" account. I've followed this through the rest of the major clients i have, and have been able to re-establish the accounts as needed for the time being.

    I'm currently looking for the setting to fix this perminately (for checkmailpasswd). Unfortunately, the only things I've been able to locate through google or swsoft directly are errors with full login capabilities being enabled or users not existing (which did exist, as in my case, but no resolution). The closest things I've found were..

    /usr/local/psa/sbin/mchk -v (rebuilds your mail configuration files, etc. Did not fix the problem for me.)

    ensuring that 127.0.0.1 is localhost in /etc/hosts (again, didn't work for me).

    And the manual switch. If anyone knows where to change the config for imapd to allow the domain to be case-insensitive, any assistance would be GREATLY appreciated at this time. I'll continue to google around for courier-imap and insensitive case, but we all know how that goes sometimes.
     
  8. JDwebsites

    JDwebsites Guest

    0
     
    I am not sure if this will help you, but I had the same problem with password checking now working until I added the file domain name next to the username. I had (under Server/Mail settings)

    "Use of short (webmaster) and full (webmaster@domain.com) POP3/IMAP mail account names is allowed" checked

    so I couldn't figure out why it wanted the whole name. Well I check

    "Only use of full POP3/IMAP mail accounts names is allowed" and click ok and then went back into the server/mail settings and checked use the short names again and it fixed the problem.

    Dean
     
Loading...