1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Enable PHP for web user

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by PlymWS, Jan 13, 2010.

  1. PlymWS

    PlymWS Guest

    0
     
    I have created a web user which has generated a directory in the web_users folder. I have uploaded files to this directory but when I try and view a php file my browser tries to download it. I suspect that php needs to be enabled for the web user.

    However when I created the web user and when I try and edit the web user the option checkbox to enable PHP support is not selectable ( greyed out ). I am logging into the Plesk panel (9.2) with the admin account so I should be able to enable php for this user.

    I've obviously missed a setting somewhere. Please could someone tell me whihc one :).

    Thanks.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Just go to Preferences for Web users and select 'Allow usage of scripts to the web users' there. After that you will be able select PHP for new Web user.
     
Loading...