1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Enable SPF spam protection

Discussion in 'Plesk for Linux - 8.x and Older' started by danielbogo, May 23, 2006.

  1. danielbogo

    danielbogo Guest

    0
     
    Which the best configuration to avoid SPANS?

    ===Enable SPF spam protection===
    SPF checking mode:
    SPF local rules:
    SPF guess:
    SPF explanation text:

    ===Enable MAPS spam protection===
    MAPS zones:

    Help
     
  2. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    read the online manual. it has the best settings mentioned
     
  3. fishnyc22

    fishnyc22 Guest

    0
     
    I followed the manual to get SPF set up (with basically the default settings) but when I check my domain on dnsreport.com it shows no DNS repor. I tried waiting a few days and still nothing.


    I also tried entering a TXT record in my domains DNS panel. I had used the SPF Wizard on openspf.org.

    Any ideas whats wrong? is there any other way to know its working? Could DNSreport.com be wrong?

    Thanks

    Fish
     
  4. jwdick

    jwdick Guest

    0
     
    Post your spf.txt record and your settings for SPF from the Plesk control panel.

    Also post the part of DNS report that you have a question about.

    If you have SPF setup on your box under <Server><Mail>, you can look at the header information on incoming emails and see the results of the spf checks.
     
  5. fishnyc22

    fishnyc22 Guest

    0
     
    Sure. thats a good idea. here it all is.... Any feedback is appreciated.


    DNS Setting for my domain:
    TXT: v=spf1 a mx mx:mail.mydomain.com. ip4:0.0.0.0(my domains IP) ~all


    Server-wide Mail Preferences
    ENABLE SPF SPAM PROTECTION
    SPF Checking Mode: Only Create Received SPF headers, Never Block
    SPF Local Rules: Include:spf.trusted-forwarder.org
    SPF guess: a/24 mx/24 ptr


    DNSReport Result:
    WARNING: SPF RECORD
    Your domain does not have an SPF record. This means that spammers can easily send out E-mail that looks like it came from your domain, which can make your domain look bad (if the recipient thinks you really sent it), and can cost you money (when people complain to you, rather than the spammer). You may want to add an SPF record ASAP, as 01 Oct 2004 was the target date for domains to have SPF records in place (Hotmail, for example, started checking SPF records on 01 Oct 2004).
     
  6. jwdick

    jwdick Guest

    0
     
    Is the "." after the ".com" just a typo? It should not be there in the record. I believe your should also have an "a:mydomain.com"

    Send me a test message to info@klicktheweb.com from your domain. I have SPF checking setup to check but not block email (to many good servers do not use SPF yet). I can tell from your headers what your domain is actually sending out.
     
  7. fishnyc22

    fishnyc22 Guest

    0
     
    Hey jwdick,


    The period was given to me by openswf. so I'm not sure if thats wrong or not now. I can try and add the a: as well.

    can I send a message from my email client here though my smtp server? I'll try that, but not sure that is what you want.

    Thanks again.
     
  8. jwdick

    jwdick Guest

    0
     
    Send the message from an account that you have on the domain that you are trying to setup the SPF txt record. What I am looking for in the header of the message that you send to me is something like:

    Received-SPF: none (mydomain.com: domain at plesk.com does not designate permitted sender hosts)

    The above is in the header information from the email that I got telling me that you had posted to this thread.
     
  9. crobinson

    crobinson Basic Pleskian

    23
    73%
    Joined:
    Aug 9, 2002
    Messages:
    36
    Likes Received:
    0
    When you use the SPF Wizzard make sure you do not copy over the " ... That will break lookups.
     
  10. mokaction

    mokaction Guest

    0
     
    Question is this what is should look like?? v=spf1 a mx mx:mail.<domain>. ip4:216.127.70.40 ~all
     
  11. jwdick

    jwdick Guest

    0
     
    Mine looks like:

    v=spf1 ip4:xx.xxx.xxx.xx ip4:xx.xxx.xxx.xx a mx a:domain.tld -all

    ~all is a form of soft fail meaning your list might not be complete. -all means the list is complete and not to allow other domains or ips.
     
Loading...