1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Enhance server performance

Discussion in 'Plesk for Linux - 8.x and Older' started by dsxs, Oct 30, 2005.

  1. dsxs

    dsxs Guest

    0
     
    Hi to all professionals

    I've got a Intel Celeron 2,4Ghz Server with 512MB RAM and Suse Linux 9.3 Pro with Plesk 7.5.4 installed.

    At the moment there are 5 low-traffic domains and a few e-mail accounts being hosted, so no big deal really.

    However, I believe the server is acting slower than it's supposed to.

    To send email, it usually takes around 20 seconds 'till the mail client is properly connected to the server and the email is being transmitted.

    Also, all the running processes on the server eat up so much RAM (of which I've only got 512MB), that the usage of such is permanantly between 95% and 98%.
    Strange about this is, that the server sometimes doesn't respond to any requests anymore - I cannot login to Plesk, no connection to the POP3/IMAP and SMTP servers, apache does not answer anymore.... this behavior stops after about two minutes and everything is back to normal again, until 15 minutes later.

    I've noticed that when I disable Spamassassin, it will free about 150MB of RAM, and the server starts to run significantly faster.
    Also, it then doesn't happen anymore that the different services stop responding for two minutes.

    So, I come to the conclusion that someting is eating up to much memory, which then causes my server to "overflow".

    In pesk, I've seen that 1GB of disk space is reserved for cache Swap. However, I've never seen the scale go further than 0% usage. Is this normal?
    Is there a way to activate the swap partition so the RAM usage will be lower?

    Here are the different proceses:


    I have absolutely no clue what most of this is supposed to be, but I'm wondering why I've got so many "spamd", or "httpsd" and "http2-prefork" processes running.


    I would be most gratefull if someone could point me to a solution to my problem.

    Thanks in advance,

    Steve
     
  2. teratec

    teratec Guest

    0
     
    Hello,

    i have the same problem. The server is very slow!!! I must wait 20 seconds before i can see my website.

    Plesk is a bad software product with many mistakes. I need one week for installing the server, but now he is very very slow with MySQL.

    Before i use Confixx 2.0 and the server was very fast.
     
  3. poke

    poke Guest

    0
     
    what mysql release are you using? and PHP?
     
  4. teratec

    teratec Guest

    0
     
    Helo,

    i use MySQL 4.0.18 on Suse Linux 9.1 and Plesk 7.5, Apache2

    I think one problem could be

    rcapache2 extreme-configtest
    Syntax: NOT OK:
    httpd2-prefork: could not open document config file /home/httpd/vhosts/domain/conf/httpd.include

    I can´t find a solution for the problem.
     
  5. CCHickman

    CCHickman Regular Pleskian

    25
    40%
    Joined:
    Oct 11, 2003
    Messages:
    112
    Likes Received:
    0
    A few things --

    First off, PLESK is the control panel -- most of the other processes, while being installed with PLESK, are independent of PLESK - such as SpamAssassin and Apache -- PLESK really just serves as a front end for configuration.

    If you run 'top' from your shell or use another method for viewing resources, you WILL most likely see most of your resources being in use. That is true of my box too -- for some reason, Linux makes the most of your resources by using them at all times [shrugs] --

    I'm not sure why teratec's sites take 20 seconds - that's ridiculous.

    I would recommend having a little more RAM to work with ... I'm on a 1&1 Box with 2GB of RAM (I think.)

    I don't use the PLESK version of SpamAssassin, rather, I installed Atomic Rocket Turtle's (and then configured it -- without configuring it, you may as well not bother) and have kept everything on my server up to date ...

    I had a problem with my server slowing down to a grind a while back where there were a huge # of child processes of both mysql and httpd -- and I found that removing and reinstalling/upgrading seemed to fix the problem.

    There are many people on this board that offer their services to help out. Some are pretty cheap - some will charge quite a bit and call you a girl's name (Atomic Rocket Turtle) - but always know what they are doing. It depends on what your needs are.

    If you are a novice in Linux, I would be glad to poke around on your box, upgrade everything, test everything to my own knowledge, and see if that corrects the problem.
     
  6. remote-admin

    remote-admin Guest

    0
     
    need tune

    Hello,

    You need to optimize mysql and apache settings for your usage.

    Best Regards,
    Dmitry.
     
  7. jshanley

    jshanley Guest

    0
     
    Quick notes

    1. Make sure you have enough file descriptors.
    2. Make sure you don't have apache configured to run too MANY processes.
    3. Make sure you have apache configured to run enough processes.
    4. Make sure you have Qmail configured not to do reverse-dns lookups, using -Rt0 .. ex:

    smtp stream tcp nowait root /usr/local/psa/qmail/bin/tcp-env tcp-env -Rt0 [...]

    5. Make sure you don't have qmail configured to run too many mail processes at one time; this will easily kill your box.
    6. Make sure you don't have SpamAssassin set to run too many processes. This will also kill your box (each instance of SpamAssassin eats ~ 7-8 mb of ram).

    There's more, but it really depends on your specific load, configuration, etc etc.
     
  8. teratec

    teratec Guest

    0
     
    Thank you very much for all the hints!!! I will try them.
     
  9. Bart

    Bart New Pleskian

    22
    57%
    Joined:
    Mar 24, 2008
    Messages:
    17
    Likes Received:
    0
Loading...