• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Ensim => Plesk Migration Error

A

acidbox

Guest
I transfered a bunch of sites from an Ensim 4.0.3 box to a Plesk 7.5.4 box using the Plesk Migration Manager. One of them, however, gave me a problem and failed:

It says:

Unable to convert the data to Plesk format:
Unable to run deploy: Empty error message from utility.

The migration.log shows:

<message code="ExternalDtdValidationFailedException" severity="error"><context>void tDtdValidator::validateXml(tXmlDocument&amp;, const cstring&amp;)</context><file>commons/xml_parse.cpp</file><line>349</line><text>Failed validation of the document with external DTD /usr/local/psa/PMM/EnsimX.dtd. The errors are: /usr/local/psa/PMM/var/dump.xml:0:Element autoresponders does not carry attribute autoresponders-enabled/usr/local/psa/PMM/var/dump.xml:0:No declaration for attribute enabled of element autoresponders/usr/local/psa/PMM/var/dump.xml:0:Element autoresponders does not carry attribute autoresponders-enabled/usr/local/psa/PMM/var/dump.xml:0:No declaration for attribute enabled of element autoresponders/usr/local/psa/PMM/var/dump.xml:0:Element autoresponders does not carry attribute autoresponders-enabled/usr/local/psa/PMM/var/dump.xml:0:No declaration for attribute enabled of element autoresponders/usr/local/psa/PMM/var/dump.xml:0:Element autoresponders does not carry attribute autoresponders-enabled/usr/local/psa/PMM/var/dump.xml:0:No declaration for attribute enabled of element autoresponders.</text></message>

Anyone know what this is?
 
Did you ever find a solution to this? I'm getting the same error and when I sent a message to Plesk about it I got the usual "Do it Manually" answer back (along with them wanting to charge me for support) *sigh*.

Steve
 
I had mixed results. A few I was able to fix, the last couple I had to do manually.

Things to check:

Make sure that the domain aliasing in Ensim is not enabled for that domain. Also delete all the domains out of the box for aliases.

Make sure the domain admin name in Ensim has a unique username, not one that is already in the Plesk system.

Remove the user from any reseller account they may be associated (set it back to none).

I did that for a few and got some good results.

There were a couple other ones that just wouldnt transfer, so I had to do it manually.

Hope this helps.
 
Back
Top