• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error in /etc/cron.weekly/50plesk-weekly

Marco Cristofanilli

Basic Pleskian
During execution /etc/cron.weekly/50plesk-weekly I have this error:

/opt/psa/bin/sw-engine-pleskrun /opt/psa/admin/plib/DailyMaintainance/script.php weekly
PleskUtilException: '/opt/psa/admin/bin/quotacheck_wrapper.sh' ' / -vunfmc' failed with code 127.

stdout:


stderr:
sh: /opt/psa/admin/bin/quotacheck_wrapper.sh: not found

file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 98
code: 0
trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
#1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
#2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('dc52d8fde2a7348...', Array, Object(Service_Agent_Log))
#3 /opt/psa/admin/plib/DailyMaintainance/execute-quotacheck.php(37): Service_Agent->commit()
#4 /opt/psa/admin/plib/DailyMaintainance/TaskRunner.php(64): include('/opt/psa/admin/...')
#5 /opt/psa/admin/plib/DailyMaintainance/script.php(97): TaskRunner->run()
#6 {main}

Do you have ideas?
 
Last edited:
Here "the same" :
run-parts: /etc/cron.weekly/50plesk-weekly exited with return code 255

PLESK 10.4.4 on debian lenny 64 and 32
 
---------------------------------------------------------------
PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
10.4.4 Debian 6.0 1013111102.18 2.6.32-5-amd64
PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
Execution of /etc/cron.weekly/50plesk-weekly
ACTUAL RESULT
/opt/psa/bin/sw-engine-pleskrun /opt/psa/admin/plib/DailyMaintainance/script.php weekly
PleskUtilException: '/opt/psa/admin/bin/quotacheck_wrapper.sh' ' / -vunfmc' failed with code 127.

stdout:


stderr:
sh: /opt/psa/admin/bin/quotacheck_wrapper.sh: not found

file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 98
code: 0
trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
#1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
#2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('16d76965e081f02...', Array, Object(Service_Agent_Log))
#3 /opt/psa/admin/plib/DailyMaintainance/execute-quotacheck.php(37): Service_Agent->commit()
#4 /opt/psa/admin/plib/DailyMaintainance/TaskRunner.php(64): include('/opt/psa/admin/...')
#5 /opt/psa/admin/plib/DailyMaintainance/script.php(97): TaskRunner->run()
#6 {main}
EXPECTED RESULT
No error

ANY ADDITIONAL INFORMATION
--------------------------------------------------------------
 
Thank you for report. I have forwarded it to developers. I will update thread with results as soon as I receive them.
 
Hi ,

i have a Server at Strato and it looks like that Strato is blocked at 10.4.4 ... i get Code 403 over my Server ...

So why can i update Plesk over the controll panel to 10.4.4 with my Strator Server and when you release MUs i can't get it ?

Please provide a link where i can download the whole MU5 and can install it manually or unblock Strato! (And please don't link to your thread for the Plesk patch...)

Thank you for your support

Marcus
 
Yes, you can try but do not forget about correct permissions.
 
thanks Igor,

could you please clarif why Strato is block and when it will be unblocked ?

Thanks in advanced

Marcus
 
Yes, we have agreement that Parallels blocks requests from Strato IPs for upgrade to Plesk 10.4.4
Contact Strato if you need to know why they requested it from Parallels.
 
hmm, ok to late because Plesk offered already the upgrade to 10.4.4 ^^

ok i will contact Strato to get my IP free ^^


thanks

Marcus
 
Any suggests? I have the same problem with my strato server... cant update to 10.4.4 running debian squeeze :(
 
Back
Top