• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue Error on upgrade to Obsidian

Steve Tozer

Basic Pleskian
Hi All,

Im just upgrading a server to Obsidian from Onyx and getting the below error. Wondering if anyone has come across this and how to resolve

Code:
Migration failed: 17.9.6/2019-04-23-11-14-00_add_recovery_email.php
Query failed: ALTER TABLE `smb_users` ADD COLUMN `externalEmail` varchar(255)
Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs
*****  problem report *****
===> Plesk database scheme was not upgraded completely.

Thanks
Steve
 
I have the same problem:
Code:
Migration failed: 17.9.6/2019-04-23-11-14-00_add_recovery_email.php
Query failed: ALTER TABLE `smb_users` ADD COLUMN `externalEmail` varchar(255)
Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs
 
I solved the problem myself, changed it in the table "smb_users" in database PSA:
- contactName: varchar(255) to TEXT
- companyName: varchar(255) to TEXT
- country: varchar(255) to TEXT
 
Back
Top