• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error: Unable to remove customer: Unable to find service node for web service on doma

SagarS

Basic Pleskian
Hi

Version:parallels Plesk Panel v10.4.4_build1013111102.18 os_RedHat el5
OS: Linux 2.6.18-238.31.1.el5

Unable to remove subscription:
Error: Unable to find service node for web service on domain with id=x

I tried activating/adding new subscription/deleting customer but its not working.

Pls help.

Thanks
 
Yes, we have already submitted bug regarding this problem. Fix expected in MU#12
 
hi
i have the same problem
so what is the result? is any solution for fix this problem
 
is there any result about this problem

Hello, Seyed AhmadS.

The issue has been resolved since 10.4.4 MU#13.

However, unfortunately, it still does not available on upgrading to 10.4.4.
It will be available since upgrading to Plesk 11. Sorry for the inconvenience.
 
Fix?

Hi same problem here, couldnt delete a domain. This worked for me:

Login to server with Putty.

Connect to psa database:
mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa

Select all from domains to view entries and see if there is something wrong with you domain:
select * from domains;

I tried to update the wrong entries, but that didnt work (after trying to delete domain from plesk, the mysql 'domains' was wrong again). So i deleted the domain by the corresponding id, in this case 6:
DELETE from domains where id='6';

Now there is one problem you need to fix, there are probably some DNS records. These can also be found in the database under 'dns_recs':
SELECT * FROM dns_recs;
DELETE from dns_recs where id='...';

And then I WAS SO HAPPY! Domain was deleted in Plesk!

Hope this will help you m8.
 
Another solution for Virtual Servers

I am also in a virtual server environment and my Plesk Build 10.4.4 is demonstrating the same problem. I am using the Business & Customer addition to Plesk and the domain that I wanted to delete was a a personal website in my webspaces. To delete I actually created a customer for this website and changed ownership, then I was able to delete the subscription without getting an error.
 
Back
Top