• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error when Deleting Subdomains

B

brandonp

Guest
When I try to delete the ftp.domain.com subdomain, I get the following error message:

Unable to create SysUser object: Unable to select: no such row in Table

Does anyone know why this message would appear?

Brandon Petersen
 
I know this is a dead post, but I've opted to include this info here in case someone was searching for a problem like mine.

I had a very similar issue when I was trying to abort an import during Migration using the tool, it left a partial domain under an account. I was trying to delete the domain and found out it had subdomains that had no FTP user listed, which cued me to think that it was trying to delete a non-existant account on the system. (If this is true or not, the fix should still work for you)

In the mySQL database, in the psa database... in the table called subdomains there could be /as in my situation/ a subdomain that isn't fully inserted. I'd remove those rows.

(Simple, but not complete instructions from root)

mysql -u admin -p
<your password>

use psa;

select * from subdomains;

Then, it's quite simple... find the one that doesn't look like the rest (;)) and delete it.
DELETE FROM subdomains WHERE <somefield> = 'it's value' LIMIT 1;

Quite simple, hope this helps.

(Someone feel free to provide more clear instruction.)
 
Thanks Whitwolf. This solved my problem during backup when I was getting this message:

Backup error.
Unable to execute ''websrvmng' --get-subdomain-performance --vhost-name=casamo.com --subdomain=dev80':

Run-Time error: Can't find subdomain 'dev80' with domain ID=10
1

By removing the subdomain, the problem is gone

Thanks again
 
Hi, i have the same problem with you . Can you please explain the solution please :) , because i still a newbie on linux . Thanx before :)
 
Back
Top