1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Error when upgrading 7.1.6 to 7.5.2

Discussion in 'Plesk for Linux - 8.x and Older' started by panda, Mar 1, 2005.

  1. panda

    panda Guest

    0
     
    I tried to upgrade Plesk reloaded on Red Hat Enterprise 3 from version 7.1.6 to 7.5.2 and it failed. I received the following error messages:

    error: Failed dependencies:
    psa-migration-manager < 7.5 conflicts with psa-7.5.2-rhel3.build75050130.17
    psa < 7.2.0 is needed by (installed) psa-agent-1.3.2-2_psa7.1
    psa = 7.1.6 is needed by (installed) psa-bu-7.1.6-rhel3.build71041118.17


    I did have a failed upgrade using the Plesk interface, and a few months ago had some problems when upgrading to 7.1.5. I don't know if these errors are a result of those earlier problems.

    Does anyone know what I need to do to get past these errors? Would it be okay in this situation to force the installation using the --nodeps parameter?
     
  2. Dimka

    Dimka Guest

    0
     
    HI


    Don't worry these dependencies are common thing all you have to do is just install .rpm's manually that are required they are listed in the error usually

    Cheers
     
  3. panda

    panda Guest

    0
     
    I got these errors when doing the update manually. What you're saying is to go ahead and override the dependencies errors in this case with the --nodeps switch for rpm?

    Thanks for the help.
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    The easiest way to upgrade is to go to Art's site (http://www.atomicrocketturtle.com) and look into his yum project. If you install yum, configure your yum.conf file per ART's documentation, it's as easy as:

    #yum install psa

    It will resolve dependancies automatically.
     
Loading...