• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error while backing up .. sometimes

T

Total

Guest
Any ideas , sometimes it works 100 % other times I get this .. Thanks in advance .. Total

Following error is occured during scheduled backup process:

Error in UploadToRepositoryState.doActivityRunner()
Traceback (most recent call last):
File "/usr/local/psa/admin/share/agent_runner/agent_runner.py", line 98, in doActivityRunner
newState = self.doActivity()
File "/usr/local/psa/admin/share/agent_runner/agent_runner.py", line 428, in doActivity
shutil.copyfileobj(localfh, remotefh)
File "/usr/lib/python2.4/shutil.py", line 25, in copyfileobj
fdst.write(buf)
File "/usr/local/psa/admin/lib/python/ftputil/ftp_file.py", line 196, in write
self._fo.write(data)
File "/usr/lib/python2.4/socket.py", line 248, in write
self.flush()
File "/usr/lib/python2.4/socket.py", line 235, in flush
self._sock.sendall(buffer)
error: (104, 'Connection reset by peer')
 
Hi.
I can suppose from the error message that sometimes the backup manager fails to connect to the backup server and the connection is dropped. You should check the ftp backup server, especially the connection to it.
 
Thanks for the reply - How can I check the connection the the ftp server ??
 
from the shell:
ftp server.hostname
instead of hostname it is possible to use IP.
If you have the access to the ftp server you can login there and investigate /var/log/messages file for possible errors
 
Back
Top