1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Event Manager - Mail account created problem

Discussion in 'Plesk 11.x for Linux' started by srobin, Jan 2, 2013.

  1. srobin

    srobin New Pleskian

    10
     
    Joined:
    Jan 2, 2013
    Messages:
    1
    Likes Received:
    0
    I'm trying to enable antivirus and SpamAssassin through the event manager right after a new mail account is created, but it is simply not working. My settings:

    Event: Mail account created
    Priority: highest(100)
    User: root
    Command: /usr/local/psa/bin/mail --update $NEW_MAILNAME -antivirus inout

    Parallels Plesk Panel's Version is 11.0.9 Update #32.

    Additional tests:
    - Tried the same settings with an existing user instead of $NEW_MAILNAME -> working.
    - Tried the same settings with the future mailadress -> NOT working.
    - Tried ${NEW_MAILNAME} instead of $NEW_MAILNAME -> no change.

    Can anybody help me?

    Best regards
    Robin
     
  2. AchimH

    AchimH New Pleskian

    10
    30%
    Joined:
    Jan 29, 2013
    Messages:
    5
    Likes Received:
    0
    Hello Robin,

    I experienced exactly the same problem with Plesk Panel 11.
    I found out, that ${NEW_MAILNAME} is resolved correctly, but spamassassin update isn't working.

    I solved it in another way. Just configured the spamassassin defaults on the server.

    /opt/psa/bin/spamassassin --update-server -status true -personal-conf false -hits 7.0 -action move -modify-subj false

    --> enables server defaults, disables personal configuration, sets spam hits to 7, move spam mails to spam folder, disable modification of subject line
    ---> Please note: Move to spam folder and modify subject line doesn't work at the same time (at least for me)

    Then type:

    /opt/psa/bin/spamassassin --info-server

    Result should be:

    ######################################
    Spam filter configuration for *@*.

    Status true
    Allow personal settings false
    Hits required for spam 7.00
    Modify spam mail subject false

    Black list
    ================================
    Server-wide black list:

    White list
    ================================
    Server-wide white list:

    SUCCESS: Gathering server wide information complete.
    ######################################

    If it's still not working, check the following:
    Go to Plesk Panel GUI -> Tools & Settings -> Spam Filter Settings
    -- enable "Switch on server-wide SpamAssassin spam filtering"
    -- disable "Apply individual settings to spam filtering"


    I havn't got a solution for automatic enabling the antivirus.
    I am creating mailboxes through the Plesk API and I enable the antivirus with the parameter "<antivir>inout</antivir>"

    Hope this helps.

    Best Regards
    Achim
     
    Last edited: Jan 29, 2013
Loading...