1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Failed to start named

Discussion in 'Plesk for Linux - 8.x and Older' started by juanqui, Sep 4, 2008.

  1. juanqui

    juanqui Guest

    0
     
    For some reason my plesk server is failing to start the 'named' service. It fails with the following error:

    Failed to start the "named" service.
    Cannot start/stop/restart service: Starting named:
    Error in named configuration:
    zone 0.0.127.IN-ADDR.ARPA/IN: loaded serial 20010622
    zone villafam.com/IN: has no NS records
    _default/villafam.com/IN: bad zone
    zone cloudsconnected.com/IN: has no NS records
    _default/cloudsconnected.com/IN: bad zone
    zone 122.14.216.in-addr.arpa/IN: loaded serial 1220535434
    [FAILED]

    I have two domains configured: villafam.com, and cloundsconnected.com

    Does anybody know what the problem is? :( I have been searching for a while but have not found the solution.

    Thanks!
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    From what you have posted it would seem that your DNS setup is wrong. Can you post it here?
     
  3. juanqui

    juanqui Guest

    0
     
    Skeleton (found in Server -> DNS Settings):

    Host Record type Value
    <domain>. A <ip>
    <domain>. MX (10) mail.<domain>.
    <ip> / 24 PTR <domain>.
    ftp.<domain>. CNAME <domain>.
    mail.<domain>. A <ip>
    ns.<domain>. A <ip>
    webmail.<domain>. A <ip>

    Contents of named.conf:

    // $Id: named.conf,v 1.1.1.1 2001/10/15 07:44:36 kap Exp $
    //
    // Refer to the named(8) man page for details. If you are ever going
    // to setup a primary server, make sure you've understood the hairy
    // details of how DNS is working. Even with simple mistakes, you can
    // break connectivity for affected parties, or cause huge amount of
    // useless Internet traffic.

    options {
    allow-recursion {
    localnets;
    };
    directory "/var";
    auth-nxdomain no;
    pid-file "/var/run/named/named.pid";

    // In addition to the "forwarders" clause, you can force your name
    // server to never initiate queries of its own, but always ask its
    // forwarders only, by enabling the following line:
    //
    // forward only;

    // If you've got a DNS server around at your upstream provider, enter
    // its IP address here, and enable the line below. This will make you
    // benefit from its cache, thus reduce overall DNS traffic in the Internet.
    /*
    forwarders {
    127.0.0.1;
    };
    */
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;

    /*
    * If running in a sandbox, you may have to specify a different
    * location for the dumpfile.
    */
    // dump-file "s/named_dump.db";
    };

    //Use with the following in named.conf, adjusting the allow list as needed:

    key "rndc-key" {
    algorithm hmac-md5;
    secret "CeMgS23y0oWE20nyv0x40Q==";
    };

    controls {
    inet 127.0.0.1 port 953
    allow { 127.0.0.1; } keys { "rndc-key"; };
    };

    // Note: the following will be supported in a future release.
    /*
    host { any; } {
    topology {
    127.0.0.0/8;
    };
    };
    */

    // Setting up secondaries is way easier and the rough picture for this
    // is explained below.
    //
    // If you enable a local name server, don't forget to enter 127.0.0.1
    // into your /etc/resolv.conf so this server will be queried first.
    // Also, make sure to enable it in /etc/rc.conf.

    zone "." {
    type hint;
    file "named.root";
    };

    zone "0.0.127.IN-ADDR.ARPA" {
    type master;
    file "localhost.rev";
    };

    // NB: Do not use the IP addresses below, they are faked, and only
    // serve demonstration/documentation purposes!
    //
    // Example secondary config entries. It can be convenient to become
    // a secondary at least for the zone where your own domain is in. Ask
    // your network administrator for the IP address of the responsible
    // primary.
    //
    // Never forget to include the reverse lookup (IN-ADDR.ARPA) zone!
    // (This is the first bytes of the respective IP address, in reverse
    // order, with ".IN-ADDR.ARPA" appended.)
    //
    // Before starting to setup a primary zone, better make sure you fully
    // understand how DNS and BIND works, however. There are sometimes
    // unobvious pitfalls. Setting up a secondary is comparably simpler.
    //
    // NB: Don't blindly enable the examples below. :) Use actual names
    // and addresses instead.
    //
    // NOTE!!! FreeBSD runs bind in a sandbox (see named_flags in rc.conf).
    // The directory containing the secondary zones must be write accessible
    // to bind. The following sequence is suggested:
    //
    // mkdir /etc/namedb/s
    // chown bind.bind /etc/namedb/s
    // chmod 750 /etc/namedb/s

    /*
    zone "domain.com" {
    type slave;
    file "s/domain.com.bak";
    masters {
    192.168.1.1;
    };
    };

    zone "0.168.192.in-addr.arpa" {
    type slave;
    file "s/0.168.192.in-addr.arpa.bak";
    masters {
    192.168.1.1;
    };
    };
    */

    zone "villafam.com" {
    type master;
    file "villafam.com";
    allow-transfer {
    common-allow-transfer;
    };
    };
    zone "cloudsconnected.com" {
    type master;
    file "cloudsconnected.com";
    allow-transfer {
    common-allow-transfer;
    };
    };
    zone "122.14.216.in-addr.arpa" {
    type master;
    file "122.14.216.in-addr.arpa";
    allow-transfer {
    common-allow-transfer;
    };
    };
    acl common-allow-transfer {
    none;
    };
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    That's not quite what I meant. That is your server's default setup. What we need to see is the domain's DNS setup.
     
  5. juanqui

    juanqui Guest

    0
     
    I dont understand what you are asking me for, sorry. How can I get that information?
     
  6. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    i think the error message says it:

    you have no ns records for the domains ...

    add your name servers with "NS" records...

     
Loading...