1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FastCGI problems after upgrade

Discussion in 'Plesk 11.x for Linux' started by KimV, Dec 17, 2012.

  1. KimV

    KimV New Pleskian

    15
    85%
    Joined:
    Nov 18, 2010
    Messages:
    8
    Likes Received:
    0
    First I upgraded Plesk Panel to the version 11.0.9 Update #31.
    Then I upgraded PHP to 5.3.19 and installed mcrypt.
    After the last 2 steps I noticed that I had problems to login to websites. (expired sessions)
    So I changed the session path of php to /tmp with the permission 777. (if there's a more secure option, please let me know)

    But I noticed in the log the flollowing error.
    Dec 17 18:19:23 vps1892 cgi_wrapper[9712]: /var/www/vhosts/mywebsite.com/etc/php.ini:No such file or directory Dec 17 18:19:48 vps1892 cgi_wrapper[9714]: /var/www/vhosts/mywebsite.com/etc/php.ini:No such file or directory Dec 17 18:19:52 vps1892 cgi_wrapper[9717]: /var/www/vhosts/mywebsite.com/etc/php.ini:No such file or directory Dec 17 18:19:52 vps1892 cgi_wrapper[9718]: /var/www/vhosts/mywebsite.com/etc/php.ini:No such file or directory Dec 17 18:20:50 vps1892 cgi_wrapper[9782]: /var/www/vhosts/mywebsite.com/etc/php.ini:No such file or directory

    Looks like FastCGI is looking for the php.ini file in the wrong place?
    How can I correct this?
     
  2. KimV

    KimV New Pleskian

    15
    85%
    Joined:
    Nov 18, 2010
    Messages:
    8
    Likes Received:
    0
    Anyone has an idea?
     
    Last edited: Dec 19, 2012
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Try to set FastCGI mode for domain manually with help of command:

    # /usr/local/psa/bin/domain -u domain.com -php_handler_type fastcgi -fastcgi true

    and check result.
     
  4. KimV

    KimV New Pleskian

    15
    85%
    Joined:
    Nov 18, 2010
    Messages:
    8
    Likes Received:
    0
    As you can see the FastCGI is enabled in Plesk:
    [​IMG]

    What I need to mention is that I upgraded to Plesk Business model and maybe this can also be the cause?
     
  5. KimV

    KimV New Pleskian

    15
    85%
    Joined:
    Nov 18, 2010
    Messages:
    8
    Likes Received:
    0
    Tried the command line and it didn't help.
    Still I see the error in the logfile that it cannot find the php.ini file in the folder /var/www/vhosts/mywebsite.com/etc/
    Why is it only for this domain? I didn't set it to use an individual php.ini file. Where can I check this setting?
     
  6. KimV

    KimV New Pleskian

    15
    85%
    Joined:
    Nov 18, 2010
    Messages:
    8
    Likes Received:
    0
    I've found the problem... Disabled "FastCGI support (required for Ruby on Rails)" where I was looking on the wrong domain.
    Now the error disappeared... but I will check the misconfig of it :)

    But I still ask myself if it is save to point sessions to the folder /tmp and set 777 as permission.
    Is there a better solution to it?
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    On my default test Plesk server installation I see :

    ~# stat /tmp
    File: `/tmp'
    Size: 4096 Blocks: 8 IO Block: 4096 directory
    Device: c2h/194d Inode: 15080816 Links: 2
    Access: (1777/drwxrwxrwt) Uid: ( 0/ root) Gid: ( 0/ root)
     
Loading...