1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Fatal: all emails are being blocked after upgrade to 8.2

Discussion in 'Plesk for Linux - 8.x and Older' started by dd285252, Aug 7, 2007.

  1. dd285252

    dd285252 Guest

    0
     
    Fatal: emails are being blocked after upgrade to 8.2

    Yesterday evening I upgraded to latest PLESK version 8.2 with several patches for QMAIL and SPAM-ASSASSIN.

    After this installation I am facing a fatal error: No one of my users can send email through my server anymore. After authenticating via SMTP-AUTH an error is coming up saying: " ... rblsmtpd: 84.169.136.47 pid 14525: 451 http://www.spamhaus.org/query/bl?ip=84.169.136.47"

    --> The DNSBL-SPAM-Blocker is now preventing every user(!) from sending email, and I mean the real users who are authenticated!

    I tried to disable the DNSBL-function via Plesk-Controlpanel, afterwards email is working fine again - but I'm becoming overwhelmed with SPAM.

    PLESK-Team, please fix this issue a.s.a.p.


    Thanks.
     
  2. dd285252

    dd285252 Guest

    0
     
    Has anybody a quick workaround for the above mentioned issue???

    I need this DNSBL function quite urgent - since it was turned off my mail users have to deal with lot of SPAM emails ...


    Or is it possible to roll-back PLESK version to 8.1.2 (or whatever it was before) ???
     
  3. gromett

    gromett Guest

    0
     
    You should use the submission port for sending. ie port 587 for sending email. It is quick and easy to configure and means when sending clients only have to do smtp_auth and skip all the other spam filtering stuff.

    Karl
     
  4. perler

    perler Guest

    0
     
    i just came about the same problem, but to change the smtp port on the client side is no option, my clients exprect to being able to send mails "out of the box".

    i wonder, what got changed in comparision to my old 7.5 plesk server..

    PAT
     
  5. huppsi

    huppsi Guest

    0
     
    same problem here, any ideas to get this working??
     
  6. dirty@

    dirty@ Guest

    0
     
    there are nothing to fix in plesk because there simply no problems... the phrase 'rbl blocks people even when they authenticate' sounds stupid because of lack of knowledge how it goes. basically rblsmtpd examines connection in the very beginning _before_ qmail-smtpd takes it, so that if you are kicked by rbl, you cannot go further and authorize...

    submission is a nice idea, but it is not fully realized in plesk yet. if your clients come from black-listed ips and kicked off, you have only three options:

    - disable rbl check

    - tell clients to go to rbl provider you use and ask to remove them from black list (or you do this for them yourself)

    - manually setup alternative port for smtp connections (w/o rbl check) for these clients and tell them to configure their mail clients to use this port as outgoing.. search for 'smtp_alt' in faq.swoft.com, there was an article how to do this..
     
  7. perler

    perler Guest

    0
     
    ah yes, i really love these "you should know how it works" people, who hide their own limited knowledge behind intimidating words..

    check here: http://xs3.b92.net/tomislavr/qmail.html#ii and check back the behaviour of plesk 7.5 (at least on debian) which was exactly as wished by a lot of people here: first authenticate, then check against rbl.

    with your "knowledge how things work" you should be aware of the fact, that almost every dial-up user's IP is in an RBL, so checking before authenticating renders an SMTP server useless for all of these users, so to ask for a solution to this problem is just fair,

    PAT
     
Loading...