1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FIX: Error in my_thread_global_end(): 1 threads didn't exit

Discussion in 'Plesk for Windows - 8.x and Older' started by tino, Dec 28, 2007.

  1. tino

    tino Basic Pleskian

    24
    23%
    Joined:
    Mar 6, 2008
    Messages:
    70
    Likes Received:
    0
    If you have Plesk 8.3.0 and use PHP 5.2.5, you will probably see this error on webpages that use mySQL connectivity:

    Error in my_thread_global_end(): 1 threads didn't exit

    If that is the case, download the PHP 5.2.1 Windows binaries from http://www.php.net/releases and extract the libmysql.dll file to C:\SWSoft\Plesk\Additional\PleskPHP5.

    Before doing so, rename the original one.

    Please check the file permissions (just make sure they are the same).

    Now you're good to go.

    Tino
     
  2. perdidos

    perdidos Guest

    0
     
    Thanks Tino !!!!
     
  3. esfahanhost

    esfahanhost New Pleskian

    24
     
    Joined:
    Feb 19, 2008
    Messages:
    19
    Likes Received:
    0
    Another Method

    this method is easy and safe
    i go to IIS and change .PHP extension from php.exe to php4isapi.dll or php5isapi.dll and resolve this problem , also you can use this method if php files show popup window for get username and password ( problem by permission in php pages )

    Go to IIS => Web Sites => Right Click on Name site for example "Test.com" and open Properties => Home Directory => Configuration => Mappings , and find .PHP from Application ISAPI extension list => Click on .PHP and then click Edit button => in Executable chage address from php.exe to php4isapi by Browse button

    for example :
    "C:\Program Files\SWsoft\Plesk\Additional\Php\php.exe"
    to
    "C:\Program Files\SWsoft\Plesk\Additional\Php\sapi\php4isapi.dll"

    First and End address use ( " ) and OK all page , now test this

    My server :
    Windows server 2003
    IIS 6
    Plesk 8.2
    php 4. and 5.
     
  4. tino

    tino Basic Pleskian

    24
    23%
    Joined:
    Mar 6, 2008
    Messages:
    70
    Likes Received:
    0
    Please note that if you do it like this, you change the working of PHP from CGI to ISAPI. Something you can do through the PLESK control panel. Many scripts won't work correctly in ISAPI mode.
    I recommend using FastCGI when ISAPI won't work. Try to avoid using CGI mode.

    Tino
     
  5. DmitryT

    DmitryT Guest

    0
     
  6. a.piras

    a.piras Guest

    0
     
    After that i did this :

    1) Restated the server
    2) Setup ISAPI extention fo the plesk domain

    After that the problem was solved. :)
     
  7. tino

    tino Basic Pleskian

    24
    23%
    Joined:
    Mar 6, 2008
    Messages:
    70
    Likes Received:
    0
    You should not have to reboot your server. Why would you do that?

    ISAPI is not a viable solution for all scripts. I remeber for example phpBB not running under ISAPI.

    So make sure that your PHP scripts can stand ISAPI mode before making the switch.

    Tino
     
  8. bizstreet

    bizstreet Guest

    0
     
    If you choose FastCGI, you cannot limit CPU (in CPU monitoring in IIS Application Pool).
    So the options are like
    1) Choose PHP 4.47 for that domain, or
    2) Run PHP5.2 as ISAPI (from the Setup option)
     
  9. virajn

    virajn New Pleskian

    22
    53%
    Joined:
    Sep 17, 2006
    Messages:
    18
    Likes Received:
    0
    Error in my_thread_global_end(): 1 threads didn’t exit

    Changing the DLL file helped me, here's more info in detail.
     
Loading...