1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Force Plesk to use existing DNS records elsewhere for Mail and MX

Discussion in 'Plesk for Windows - 8.x and Older' started by msams99, Apr 29, 2004.

  1. msams99

    msams99 Guest

    0
     
    My customer has an existing Exchange server that is hosted seperately from their web site. I have set up a domain for them (domain.com) and there are some ASP scripts on the website that I am testing. I have not redelegate the domain yet, and the client runs their own DNS anyways. Everytime the ASP script sends an email to someone@domain.com Plesk tries to deliver the mail locally (to the catch all mailbox). I want Plesk to send the mail to the actual MX record for the domain.

    I tried switching off Mail for this domain, but the emails are still going to the catch all mailbox. Is there anyway to force Plesk to use the regular DNS records, specifically the MX record, and deliver any and all mails from ASP or other domains on this box to their Exchange server?

    Thanks you for any help!
     
  2. softpac2000

    softpac2000 Guest

    0
     
    Go to your server windows directory and edit the php.ini file.
    Go to the section called [mail function] and change the
    SMTP = localhost
    to
    SMTP = mail.yourdomain.com
    or whatever your mail server name is...

    Hope this helps!
    Ricardo...:cool:
     
  3. msams99

    msams99 Guest

    0
     
    Thanks for the idea softpac2000, however I am looking for a general way to turn off mail and use the current MX record for whatever the reason, not just PHP. In fact I am not even concerned with PHP at the moment, I am trying to get it to work with ASP and with other domains hosted on the same server sending mail to domain.com.

    Thanks for the suggestion though.
     
  4. msams99

    msams99 Guest

    0
     
    bump...

    Someone suggested a technique if I was running plesk on a linux box like this:

    * remove the domain from /usr/local/psa/qmail/control/rcpthosts
    * then restart qmail

    Does this give any ideas to anyone for my windows version problem?

    Thanks.
     
  5. softpac2000

    softpac2000 Guest

    0
     
    If I am not wrong, I beleive Plesk (Horde) works with PHP, that's why I sugested the changes above.

    But I just noticed you want to do this only for a specific client.... and not globally!....

    Try this if you haven't already!...

    Go to your clients domain DNS and replace the MX record if you havn't done so already!

    <domain>. MX (10) mail.yourclientmailserver.com.

    Also make sure that under the Client / Preferences, the Webmail is not enabled!...

    Also type ipconfig /flushdns on the command prompt to clear the resolver cache!

    Try all this to see if it works for you! I beleive it will!...

    Hope this helps!
    Ricardo...:cool:
     
  6. EclipZ

    EclipZ New Pleskian

    23
    20%
    Joined:
    Nov 1, 2002
    Messages:
    17
    Likes Received:
    1
    :D That's the right idea, the domain needs to be removed from the local delivery rules altogether so MX is looked up and mail handled by the external server instead.

    Searching the forums there doesn't seem to be an answer for the Windows version - probably because it's so new, has anybody successfully implemented an external mail server setup for a domain hosted on a Windows Plesk box yet ? :confused:
     
Loading...