1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Frontpage Error - Wrong Server Type?

Discussion in 'Plesk for Linux - 8.x and Older' started by NightStorm, Apr 22, 2005.

  1. NightStorm

    NightStorm Guest

    0
     
    I'm not exactly sure when this error started, but it's causing some disturbance with my customers all of a sudden.
    Seems that sometime in the last week or two, Frontpage decided to break itself.
    We now receive the following error when clicking on the Frontpage Management button in Plesk:

    Server Error: Unknown web server type " ". On Windows platforms, Microsoft Internet Information Server is supported. On UNIX platforms, Apache with the Microsoft FrontPage patch is supported

    I have tried removing the Frontpage RPM and reinstalling it through the Plesk Updater page, but the error just will not go away.
    Any ideas on what happened here, and how I can fix it?
    Server details:

    OS Linux 2.4.21-4.0.1.ELsmp
    psa 7.5.2-rhel3.build75050130.17
    httpd 2.0.46-46.highfd.rhel3.art
    frontpage 5.0.2.2634
    php 4.3.11-1.rhel3.art
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    try uninstalling the FP you have and try installing ART's frontpage-5.0-70psa.rhel3.i586.rpm using yum.
     
  3. Griffith

    Griffith Guest

    0
     
    Have you found any solutions for this?
     
  4. NightStorm

    NightStorm Guest

    0
     
    Yeah, sorry.
    There was a setting in mod_security that was hiding the server make and version from users (those who would get a 404 error or whatever would not see the server build in the error page), and it was interfering with the Frontpage module.
    Commented out the setting, and it was all good.
    Credit the help at ART Forum for figuring this out.
     
  5. Griffith

    Griffith Guest

    0
     
    Worked when I commented out this:

     
Loading...