• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

FTP connection dies midway through transfer

cmaxwell

Regular Pleskian
One of our servers is having a problem with FTP. It begins file uploads and after about 1MB of data transfer the connection drops.

If we disable the iptables firewall then it works fine.

I set the passive ports in /etc/proftpd.conf:

PassivePorts 49152 65534

And opened the ports in the firewall:

/sbin/iptables -A INPUT -p tcp -m tcp --dport 49152:65534 --syn -j ACCEPT

Other than this we don't have any other customisations on the firewall.

Any ideas? I'm guessing it's a problem with the firewall but find it very strange that it starts the file transfer then stops.

Thanks.

- Chris
 
Does anyone have a sample iptables file that works well with ftp.. I'm having similar issues. Just a directory listing via ftp takes like 5 seconds with firewall on.
 
We found that this problem was caused by the first rule in the firewall:

-A INPUT -p tcp -m tcp ! --tcp-flags SYN,RST,ACK SYN -j REJECT --reject-with tcp-reset

Try removing that rule from your firewall ruleset and it should start working.

- Chris
 
Back
Top