1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

GoDaddy's Fedora Plesk systems will not migrate!

Discussion in 'Plesk for Linux - 8.x and Older' started by dave5b03, Jan 22, 2008.

  1. dave5b03

    dave5b03 Guest

    0
     
    GoDaddy has required all their customers to upgrade to Fedora 7 by March 15.

    However, the GoDaddy Plesk systems will not migrate! I have tried to migrate both Fedora 2/Plesk 7.5.3 and Fedora 6/Plesk 8.2 to Fedora 7/Plesk 8.3 with no success.

    I get the same error regardless of which version I try to migrate:

    Failed to execute scout.
    The return code is 9
    The output on STDERR is
    "use" not allowed in expression at - line 4, at end of line
    syntax error at - line 4, near "<mypasswd>
    #!/usr/bin/perl

    use strict"
    BEGIN not safe after errors--compilation aborted at - line 16.

    On one of the systems I ran ./scout and got the following result:

    [root@www PMM]# ./scout.pl
    <?xml version="1.0"?><scout-result><detected-panel agent="PleskX" name="Plesk 8.2.0 FedoraCore 6 82070706.15"/><os-info os="Lin ux" loadavg="0.08 0.02 0.01"/><remote-fs><fs mountpoint="/" device="/dev/vzfs" mode="rw" size="10737418240" free="10011987968" type="reiserfs"/></remote-fs></scout-result>

    Who is responsible for this error? I think it is reasonable to expect that a system provisioned with Fedora and Plesk to migrate Plesk when you pust the Plesk "migrate button".

    Is this a SWSoft Plesk migration programming error or is it a GoDaddy provisioning error?
     
  2. dave5b03

    dave5b03 Guest

    0
     
    I think I have answered my own questions; the error messages were confusing.

    The problem appears to be SWSoft documentation indicates the source host /etc/sudoers file should contain 'user ALL=(ALL) NOPASSWD: ALL'.

    That does not work on the GoDaddy servers, you require 'user ALL=(ALL) ALL'.
     
Loading...