1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Help - Cant Start MYSQL Service

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by DanH, Aug 18, 2009.

  1. DanH

    DanH New Pleskian

    19
     
    Joined:
    Aug 18, 2009
    Messages:
    4
    Likes Received:
    0
    Perhaps you guys will laugh at this, I thought I knew what I was doing.

    Basically I wanted to add ft_min_word_len=3 to the /etc/my.cnf file.

    I changed it , typed in mysqld - restart

    The service restarted, however when checking the config settings, nothing had changed.

    I screwed with this one or 2 times, modifying the syntax slighly, however nothing worked.

    I Then decided I was changing the wrong my.cnf file and reverted to a backup of the original file and saved it over the file I had been modifying.

    When I try to start the service I get the following error message :

    Number of processes running now: 0
    090818 17:56:32 mysqld restarted
    /usr/libexec/mysqld: Too many arguments (first extra is 'ft_min_word_len=3').
    Use --help to get a list of available options

    I've checked and re-checked the my.cnf file, it definitely does not contain ft_min_word_length option. For the record, here is the my.cnf file.

    [mysqld]
    set-variable=local-infile=0
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    user=mysql
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1

    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid


    What am I doing wrong? I am unable to log into the Plesk panel until this is fixed. Please help.

    Regards
    Dan
     
  2. Andrey Kucherov

    Andrey Kucherov Guest

    0
     
    Hello,

    Here is the configuration file from our test server. Probably this will help you:

    ===

    # less /etc/my.cn
    ---
    [mysqld]
    set-variable=local-infile=0
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    user=mysql
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1

    skip-bdb

    set-variable = innodb_buffer_pool_size=2M
    set-variable = innodb_additional_mem_pool_size=500K
    set-variable = innodb_log_buffer_size=500K
    set-variable = innodb_thread_concurrency=2
    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    skip-bdb

    set-variable = innodb_buffer_pool_size=2M
    set-variable = innodb_additional_mem_pool_size=500K
    set-variable = innodb_log_buffer_size=500K
    set-variable = innodb_thread_concurrency=2

    ===
     
  3. DanH

    DanH New Pleskian

    19
     
    Joined:
    Aug 18, 2009
    Messages:
    4
    Likes Received:
    0
    Figured it out. Problem was that I edited the my.cnf in a windows based text editor. Somehow, the file was converted to a different format to its original. When viewing in windows, the file did not show the ft_min_word_length line. However when I edited the file from the command prompt using #vi /etc/my.cnf - the line was there in plain sight. All I needed to do was delete it - MYSQL started fine afterwards.

    Strange this, as I originally put the line into the my.cnf file from a windows text editor.
     
Loading...