• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Horde 'error code 127' problem

GiorgosI

Basic Pleskian
Plesk 10.1.1
CentOS 5.5 x64

When we try to send email from Horde we get the error:
There was an error sending your message sendmail returned error code 127

the same time there is the error in /var/log/httpd/error_log:
sh: /sendmail: No such file or directory, referer: http://webmail.xxxxxxxx.tld/imp/compose.php?uniq=1302686268041

I found that the problem is caused due to php safe_mode being On in /etc/php.ini.
If I switch safe_mode to Off, webmail works. The problem is that safe_mode must be On in /etc/php.ini.

Php is running only in CGI mode(server is a container with template 'Pp10 vps optimized' insalled, so php runs only in CGI mode), so I cannot apply php_admin_value in horde's config file.
How can I change safe_mode only for Horde when php is running only in CGI mode?

Thank you
 
I got answer from Plesk support.
I cannot change Horde's or Atmail's safe_mode when php is running in CGI mode.
So, in this case Horde and Atmail get this parameter from global configuration, /etc/php.ini.
 
Back
Top