1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Horde 'error code 127' problem

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by GiorgosI, Apr 13, 2011.

  1. GiorgosI

    GiorgosI Basic Pleskian

    21
    73%
    Joined:
    Nov 6, 2009
    Messages:
    64
    Likes Received:
    3
    Plesk 10.1.1
    CentOS 5.5 x64

    When we try to send email from Horde we get the error:
    There was an error sending your message sendmail returned error code 127

    the same time there is the error in /var/log/httpd/error_log:
    sh: /sendmail: No such file or directory, referer: http://webmail.xxxxxxxx.tld/imp/compose.php?uniq=1302686268041

    I found that the problem is caused due to php safe_mode being On in /etc/php.ini.
    If I switch safe_mode to Off, webmail works. The problem is that safe_mode must be On in /etc/php.ini.

    Php is running only in CGI mode(server is a container with template 'Pp10 vps optimized' insalled, so php runs only in CGI mode), so I cannot apply php_admin_value in horde's config file.
    How can I change safe_mode only for Horde when php is running only in CGI mode?

    Thank you
     
  2. GiorgosI

    GiorgosI Basic Pleskian

    21
    73%
    Joined:
    Nov 6, 2009
    Messages:
    64
    Likes Received:
    3
    I got answer from Plesk support.
    I cannot change Horde's or Atmail's safe_mode when php is running in CGI mode.
    So, in this case Horde and Atmail get this parameter from global configuration, /etc/php.ini.
     
Loading...